System Audio Recorder not working

I have a Macbook (the model from 2016) and I’m using the newest version of Audacity, 2.1.3. I usually use it to record streaming music, and it has always worked out fine except last night it stopped picking up any sound when I use the “system audio recorder” option. I have no idea what I did, but now when I try to record any music from my laptop nothing records. Can someone help me? It was working just fine a few days ago!

Which Mac version do you have? Apple (upper left) About…

I have a MacBook Pro, the model is from early 2015 I think. It’s not the newest one, but the second newest. My audacity version is the Mac compatible version 2.1.3.

I have a MacBook Air about the same age. From the desktop, do you see the little black apple in the far upper left?
Screen Shot 2017-04-05 at 16.40.13.png
Click on that > Click About This Mac

It should say OS-X and some version number.

What’s yours?

I don’t see any application called System Audio Recorder. Are you selecting this from inside Audacity?

I think this is causing many puzzled looks because traditionally, Macs had no natural provision to record themselves. Unless you added an App or other software, Macs will not record YouTube or other on-line sound. So what you have now is perfectly normal. It’s supposed to record nothing.

I use a tool called SoundFlower and that allows me to record Mac internal sound and internet shows. But when I got the Mac out of the box, it didn’t work any better than yours does now.


Really? My computer’s audacity has a “system audio recorder” option on the devices bar thing. It’s always worked fine before, and it won’t work. I’ve been able to export and record streaming audio straight from audacity. I’ve attached a snapshot of what it looks like on my laptop.

I tried to download Soundflower, but it looks like it hasn’t been updated in a few years because whenever I try to open the disk image for it my computer says it’s too old to download. How are you using Soundflower?

Macs do not come with “system audio recorder” - you installed it, intentionally or otherwise. Neither do Macs come with “Loopback Device” - it looks like you have been experimenting with different streaming recorders. Mac System Report will tell you who claims to make these applications.

Apowerstoft is usually regarded as malware - I would get rid of it.

To try Soundflower, use “Soundflower-2.0b2.dmg” as described on

Please make sure you have copyright holders’ permission before recording audio from the internet. This is a standard disclaimer to protect ourselves.


Ok. Yeah, last week I tried to download some other audio recording devices when audacity stopped working. I’ll get rid of Apowersoft and Loopback audio. I had no idea any of those were malware, since lots of websites recommended them.

Also, last night I downloaded Soundflower but I had the same problem when I tried to use it- no audio is being recorded when I click “record.” It’s just a flat line.

Don’t worry, I’m not recording anything copyrighted.

I have absolutely no idea how I downloaded something that gives me the “audio system recorder” option, since all I did when I got my new laptop was clone my old computer onto my new one. My old computer does not have a “system audio recorder” option on Audacity, but I just assumed that was because my new laptop offered some new capability.

Go through carefully. Some step you are missing may be why you are recording a flat line.


Could it be you had Adobe Audition installed in the past?

I seem to remember this “System audio recorder” coming with it.

I’ve downloaded soundflower 3 times now, and have been as careful as I can be (although all it is is clicking “ok”) and audacity is still not recording any audio on any device I choose except “Built in microphone.” And now even when I record using the built-in microphone, there is this horrible screechy noise.

My audacity system audio recorder is very weird; it records system audio fine for maybe 3 days, and then the next day is doesn’t work. It didn’t used to be this fickle, it started happening 2 weeks ago when I made this post.

I have no idea if it’s a computer issue, because on Quicktime you can also record system audio, and whenever I try using that instead nothing gets picked up there either.

PS- I also tried installing/using Soundflower with audacity on a family member’s computer (which is also a Mac) to see if it’s just my own laptop that is the problem. Soundflower also didn’t work there either! Are you guys sure Soundflower actually works?? What am I doing wrong?

Again, that application is nothing to do with us.

Macs do not intend you to record computer playback, so any application that tries to do this has to go through a lot of hoops.

Having different applications trying to record computer playback in competition with each other is a terrible idea and probably why none of them work. So uninstall all of these applications except one, and then try each one. I would just get rid of Apowersoft if you have not already do so.

You may need to uninstall kernel extensions to get properly rid of any of these. See the documentation that came with the application. Mac System Report (Apple Menu > About This Mac) might be able to tell you who claims to make the apps other than Soundflower.

If you want to get properly rid of Soundflower 2.0.b2 (perhaps to try installing it again) I think the commands to run in the Terminal are:

sudo kextunload /Library/Extensions/Soundflower.kext

You will have to enter your admin password.

When the unload is successful

sudo rm -r /Library/Extensions/Soundflower.kext

Restart your computer for the changes to take effect.