Switched to Mac, Audacity not recording

Hello all,

The great day finally came when my long time wish came true and switched to Mac from PC … however I can’t get Audiacity to record when playing sounds/music on the new machine. I tried playing with the settings but still getting flat line. Trying to capture some song from VLC as a test but no luck. Current settings: ‘Core Audio’ - ‘Built-in Input’ - ‘2 (Stereo) Recording’ - ‘Built-in Output’

I am on a MacBook Pro with OX 10.13.3, Audiacity is 2.4.2.

[u]Recording Computer Playback on a Mac[/u]

If you’re in 10.13 (High Sierra), Soundflower should still work.

Do Not upgrade your Mac. 10.13 is still supported (as far as I know). Mojave is inconvenient and Catalina broke a lot of things.

I Need to drop for a while.


That was harder than it should have been.

I made a SoundFlower ReadMe in plain text. The one included with the program is formatted and still has all the formatting codes sprinkled around it. You can read that one if you have all week.

It does open beautifully in my Publisher program. Doesn’t help.

This is the latest app. 2.0b2

Archive.zip (38.8 KB)
There are some tricks to using it.

As we go.


Thanks a lot Koz, this does work, I set output in VLC to Soundflower and as input in Audiacity and works great! I guess the only drawback is that you can’t hear the sound while recording but it’s not a big deal most important is that I can capture sounds again. Thanks again Koz!

you can’t hear the sound while recording

Sure you can. Set the Audacity playback device to your speakers, headphones, or other “real” sound device. Then set Audacity > Preferences > Recording > Playthrough.
That sound may be a fraction of a second late, but if you’re waiting for a sound cue, that may be enough. I’ve been known to transfer vinyl with that set and I can hear the slight time difference between the tiny sound from the needle and the record monitor.

From memory now, I think you will see the recording and playback meters jump when you do it this way.

There was another product called something like SoundFlowerPot or some such. I never used it, but I think that let you automatically switch between services and sound pathway directions. I don’t mind the extra click or two needed to get plain SoundFlower to do everything I need.

I think there is a different product also in the Audacity instructions.


I see … yeah I got it to work, like you said there is just a little pause at the beginning but pretty much starts the same time, I don’t mind it as long as it works. I wonder if this glitch will be fixed at some time, I was also just reading that Catalina has issues because of some permission problem but on YouTube someone has a solution for it by running a short line of code using the terminal, then he says it works again. For now I am not planning to upgrade from High Sierra anyway.

Thanks again for all the suggestions and the patch!

I wonder if this glitch will be fixed at some time

Nobody’s touched support or updates on this program since the Renaissance. That code came from my installer archives. I was surprised you could still get the original download. Somebody must be keeping a server alive in their garage the developers having long since given up and moved to a different state.

That’s not the only way to get magic software. There is a very good audio compressor and processor called Chris’s Compressor. He designed it so he could listen to opera in the car. It removes the wide dynamic loudness range without seriously affect anything else. It has a few minor problems which will not get fixed because Chris reached end-of-life.

That’s totally not the only way to do self-recording, though.

I think this is the officially supported technique.


Desktop > Go > Utilities > Activity Monitor > Disk.

Run some of your favorite programs and watch the “Kind” column. Any time it says 32, that software is going to drop dead in Catalina, doesn’t matter what your license says.

In my case, my off-air “TV Set” will drop dead and my web site administration software will stop working. That’s a partial list. I think my document publisher goes away, too.

on YouTube someone has a solution for it by running a short line of code using the terminal, then he says it works again.

That’s not Support. That’s a work-around. Yes, there’s a bunch of those floating around here, too. That’s the difference between want and need. If you need everything to work, then it needs to be supported. There’s nothing quite like having an error on a paying job and be stuck because you need to find the users with the same work-arounds that you used to fix it.