Super tiny yet audible clicks


This is an ongoing issue which I have been struggling with for years and have reported before, and have read several posts and advice on this forum and online ranging from completely different solutions to there is nothing that can be done. By following some advice I have reduced this issue, but not completely.

I can’t accept that this can’t be completely fixed.

During my voice recording via Yeti Pro mic directly to Audacity, I get tiny, tiny-weenie clicks which are still audible. They used to be much bigger, and I was able to significantly reduce them by increasing the buffer setting from 100 to over 500 - and yes, it worked!

To an extent.

I can remove clicks between the words, but not those under the voice. I tried the “click removal” feature - it doesn’t help, as it changes the audio quality of the voice which I can’t do. So if they are audible, I have to re-record that section, and having to do many times in the project, it adds a significant amount of time to my workflow, which is really bad.

It’s not the mic issue, by the way. My voice recordings on Zoom where I use the same mic and are also saved locally on my computer - do not have those clicks. So that’s an important clue, pointing to Audacity.

It looks like the buffer length holds the key (not so much latency, unless these two values must always have the same relationship).

Would you be able to advise please:

  1. is there a fixed relationship between the buffer and latency settings? All I know is that latency is a negative value.
  2. I tried the buffer setting from 100 to 600 - a higher value seems to help, but if I don’t change the latency accordingly, this could be still an impact.
  3. If the mic and Windows sound card are excluded by the non-affected local Zoom recordings - what do I need to change in Audacity to eliminate those tiny clicks?


The clicks could be skipping: Audacity being interrupted momentarily by other processes on the computer.
Giving Audacity “Above Normal” CPU priority is worth a try, (so less likely to be interrupted)

that’s a good call, but I don’t think this is the issue in my case.

these clicks are not skipping but more like interference.

I can actually hear them during the recording.

How can I give Audacity Above Normal CPU priority?

via Windows Task manager

Post one of the clicks. Drag-select a portion of performance with some short spoken work and then a tick over silence.

File > Export > Export Selected as WAV and post it on the forum. Scroll down from a forum text window > Attachments > Add Files.

If you haven’t done that during any of the requests for help, then we’re just guessing at the possible causes.

I can actually hear them during the recording.

That’s significant right there. How are you listening? Headphones plugged into the Yeti Pro? That’s the only way you could listen to yourself during a performance (recommended) without computer delay or distortion.

That means the click is coming from the Yeti Pro.

It doesn’t have to be a broken Yeti. The Yeti gets its power from the USB connection and it could be responding to a ratty computer USB service. As I’m sure someone pointed out before now, Skype, Zoom and other services take over the computer when they work and you don’t have anything to say about it. If your voice is clean during a Zoom call, then Zoom is doing something special to the computer to get that result.

That doesn’t get us anywhere because Zoom computer changes can be extraordinary which is one of the reasons it’s difficult to record both sides of a Zoom call locally. You’re fighting some very talented engineers in the Zoom corporation.

I have been struggling with for years

That’s where we part company. I would be recording on a different computer or be recording my voice using a completely different system.

The Yeti Pro has an XLR connection on the bottom and will plug into any sound mixer or good quality, stand-alone sound recorder.

You don’t need to buy two computers. Borrow your mum’s machine. Audacity is free and it will tell you in one swoop if the machine is doing something to cause the problem. Even if it gets worse, that’s valuable to know.

There are oblique solutions, too. In the early days of The Yeti Curse problem, we determined that you could use a wall-powered USB hub and simply don’t plug anything into it but the Yeti. The Yeti family has had noise problems for years. We designed a software solution to that one which reduced the problem to a minor annoyance, but we also determined that the only sure 100% cure was change the computer.

Another sure cure version tells you to stop recording on the computer. I like my Zoom H1n recorder and there are people turning out good work on the other Zoom models. They don’t have computer problems because there’s no computer.

This is a workup on the Kitchen Table Sound Studio featuring my Zoom H4 recorder (now deceased).

Scroll down.


One other note. The Audacity blue waves in a normal display only show you the loudest 25dB or 30dB of the performance. You can hear far quieter than that, so you can hear “magic” problems that don’t appear on the timeline.


Hi Trebor

thanks for that - I was not aware of this options.

however, when I right clicked on the program and on Priorities - when I changed it to Above Normal - I got a warning message:

Changing the priority of certain processes could cause system instability.

Are you sure this is safe?


thanks for your thoughts.

I will upload the recording.

To address your questions in the interim:

I did change my computer several months ago to a brand new one.
Borrowing a computer from someone else is not an option, especially from my mum who is now deceased.
I have a laptop (Windows) which I could potentially test it on.
I do listen via headphones plugged into the mic.
Recording on a sound recorder is not an option for me at this stage.
Room echo is not an issue for me.

You didn’t address the buffer/latency settings at all, while this seems to have the biggest impact on those clicks, and which feature in many online posts about such tiny clicks as the only solution.


“Above Normal” is safe. Don’t go higher than that.
The other higher priority options e.g. “RealTime” can cause the computer to lock-up.
Setting Audcaity CPU-priority to above normal (but no higher).gif
[BTW this is not a guaranteed fix, it’s just worth a try].

There’s another possibility. Make it so you don’t have to mess with priority.

Close everything you can except Audacity, or better still, don’t launch other jobs in the first place.

From your first display, DropBox, Explorer (multiple times), and other applications that have little or nothing to do with recording your voice are active.

There are several applications there for the purpose of managing your purchases at the Microsoft Store.

Can you disconnect your network? Is it on a cable that you plug into your machine? Are you on WiFi exclusively? Google how to suspend or close the connection.

Clean Shutdown the machine. Start it and see if Audacity runs OK by itself with no other applications running.

Shift+Shutdown > OK > Wait > Start.

Note any messages you get during this shutdown.

I know the goal is to make the ticks go away, but any change is good news. If you change something and the problem gets much worse, that’s good to know.

Is this a laptop? Does the problem change when you plug it into the wall or unplug it? There are some performers that have such noisy wall power that they have to record on batteries. This is an additional advantage that the stand-alone sound recorders have.

There is an uncomfortable possibility, too. Since all the symptoms so far are contradictory or impossible, maybe the problem is impossible. Maybe you’re making it all up to drive us crazy. We look forward to your posting of the problem sample.


You didn’t address the buffer/latency settings at all

Because I don’t think it’s going to help. We have some nasty experiences with Yeti microphones. While we were struggling with The Curse, we went for weeks making tiny settings changes here and there and we were able to make tiny improvements here and there, enough to get everybody’s hopes up, but were never able to completely cure the problem to the point of making good quality recordings.

Until we changed the computer.

You are using a new computer and seem to not fit into that scenario, but is your new machine similar to your old one? Same manufacturer? You see where I’m going with this? You didn’t actually change the machine. You went from Model A to Model B of the same machine.


well…I might if I wasn’t so busy and had nothing better to do…

I’m having a break from recording so at the next opportunity will try to catch those clicks and upload them for your inspection.

Also, in the meantime and for other reasons, I have updated my HP bios, firmware and drivers. So let’s see what happens.

well, I think we are dealing with the quantum observer effect here.

I was working on few urgent recordings over the past few days, and had plenty of those clicks. I had to work very fast though and didn’t have time to save them, just cleared them as much I could.

now, I sat down with the intention to record a test audio for you with those clicks, and…they are almost gone…nothing I could really capture.

So either it is the upcoming full moon (tomorrow) or the quantum observer effect, other than that - my mic is scared of Koz (and who wouldn’t be!) dissecting its recording and uncovering its dark secrets…

So I need to wait for the day and time when those clicks are back to capture them for you.


they are almost gone…nothing I could really capture.

Those are the best aren’t they? Developers/Programmers have a failure called “Moon Phase Errors.” Their program crashes erratically seeming to follow the third quarter after a full moon. Then, nothing. Works perfectly for a month.

It’s good to note any change. I know your goal is to make the problem vanish, but note if you do something that makes it worse, changes it, or introduces other problems.

There are posters that insist, “They didn’t change the machine at all.” They didn’t have to. The act of using the machine changes the capacity of the internal drive and the environment can cause heat shifts. Laptop batteries get “soft” and less reliable as they age.

You can have ambush problems. Audio (and Video) can exercise a machine’s memory more than other applications. Memory defects can arrive in those two apps that can otherwise say hidden for years. People trying to keep a whole audiobook alive at once can run into this one.

Then there are seriously evil problems. You’re not the only user on your machine. There is an app that’s “borrowing” your drive to serve files to the country of Souvlaki to benefit the rebels there. (I think that’s from Bette Midler at The Baths.)


The Bette Midler performance is Kreplach, not Souvlaki. Forgive me.

I know there must be one or two of you out there
Who haven’t got the vaguest idea what … is a Kreplach
And to both of you I say…
A Kreplach is a person from Kreplachia
Which is a very small fishing nation wedged between Estonia and Latvia


My feeling was that this is the mic issue.

But the evidence contradicting that feeling and perhaps the strongest clue is that when I do Zoom recordings - which are saved locally ( don’t know if they are recorded locally or on the Zoom server) - using the same mic and same everything - there are NO CLICKS.

My voice recorded on Zoom sounds slightly differently and the waveform looks different, positioned higher on the audio track (more in the 0.0 to 1.0 range than 0.0 to -1.0) while my voice normally recorded sits lower. But I guess that’s normal with Zoom.

This would point to the sound card or broadly to the processing and recording of the mic audio on my PC. Which is the second PC having this problem.

But now we are back to square one and are going in circles, so I just need to capture those clicks when they happen before they drive me completely crazy as it takes time to remove them between the words and re-record the words with clicks underneath, or just leave them in which sounds unprofessional.

What’s the max file size to upload here? in what format?

Ten seconds in perfect quality WAV format. 2MB.

If you are having noise problems, it’s a good idea to post the noise in addition to what you consider normal voice or instrument performance. That’s gives us a relationship/starting place.

Occasionally, someone will post noise-only and it turns out they were “Diving For Noise” and the noise they discovered down in the atomic level would never have interfered with the performance.

Just to cover it, did you try changing Preferences > Devices > Latency > Buffer settings?


ok thanks.

no noise issues.

Yes I have changed the latency - buffer settings several times.

One notable improvement was when I significantly increased the buffer from the default 100 to 560. The clicks went down by 80%.

The current settings are buffer 240, latency -50.

When I was researching the buffer - latency impact on clicks (there are some articles talking about this very issue!), I found it really confusing that there is such a disparity of claims and often completely contradictory advice, whether to do with the buffer or latency in relation to clicks.

That advice ranges from “make sure that the buffer number divides by 120”, to “reduce the latency to the bare minimum”.

Could you possibly shed some light please on this relationship and clicks?

Could you possibly shed some light please on this relationship and clicks?

Not me. I’m a Mac elf and I’ve never had any problems like this over multiple machines.

I can’t wait to inspect those clicks. We’re pretty sure they’re going to fall into one of two camps. Tiny portions of the performance missing, or something actually making tiny noises.

The missing portions can seem to be magic because they’re audible only when they interrupt some sound. If you get them during silent segments or room tone, they don’t sound like anything, even though they are still there.


I don’t think you ever told us if this is a laptop.