Suddenly there is no more sound coming from Audacity

Suddenly there is no more sound coming when playing back a file in Audacity.

Other applications like YouTube still work normally. The files I tried to play in Audacity did work earlier with the same version of Audacity. The only thing I can imagine that may be different is that I installed another media player, which I uninstalled in the mean time, of which I forgot the name (a three-letter name and it asks you to drag and drop the file to play it). The ouput device is set to “Default”. I tried all other options, but either they give an error or they have the same effect as “default”, i.e. no sound. I tried to reinstall Audacity and reboot my PC, but still no sound. In the right upper corner the playback volume is at “1.00 (emulated)”. It looks like something is muted, or that another application is stealing the audio output, but I cannot find which. I have Audacity 2.4.2 installed on Kubuntu 22.04.3. LTS. I do have two sessions of NoMachine running, but that was no problem in the past.

I tried using earplugs rather than the external loudspeakers, but the result is the same. YouTube works, but from Audacity no sound is coming. Then restoring the loudspeakers, again YouTube works, but no sound from Audacity.

Problem solved. ALSA was at 100% volume, but there was a little button beside that said it was muted. I clicked on it, and got sound again.