Suddenly no playback sound on Ubuntu 10.04

I have been merrily using Audacity for years. Now, suddenly, I cannot get any output sound. Some things work OK (Musescore, VLC) on the front audio plug, nothing works on the rear audio plug. I have not changed the configuration - wouldn’t know how to! No other applications are running. Boot changes nothing.
Ubuntu 10.04, Audacity 2,05.

Ubuntu 10.04 is no longer supported by Canonical. You may want to upgrade to the current 14.04 assuming your computer meets the requirements. Then the Ubuntu Forums will help you too.

The recommended (I would say minimum) for 14.04 is 1 GB of RAM and 1 GHz processor. The standard Ubuntu 14.04 will be very slow on such a machine, but there is the more lightweight lubuntu.

Assuming you mean Audacity has no sound, choose the “pulse” or “default” playback device in Audacity’s Device Toolbar so that Audacity will not lose sound when some other application is using the sound device.

Install pavucontrol (PulseAudio Volume Control) for finer control of volume. You “may” be able to install pavucontrol from this link

If not, install it using the terminal

sudo apt-get install pavucontrol


Thanks for the reply. I meant 14.04. (Getting old!)
Figured out that it works ok using the socket on the front of the machine, but has stopped working with the socket at the back. And also only works when I use HDA Intel PCH: ALC887-VD Analog (hw:1,0) as the output device. Nothing else, including default, works.

“Default” uses the system default, which on Ubuntu 14.04 is “Pulse”. When using Pulse (PulseAudio), the output depends on how PulseAudio is configured. If you have “PulseAudio Volume Control” (pavucontrol) installed, then you can use that to configure Pulse.

The “hw” options are the hardware devices. Selecting the “hw” option bypasses PulseAudio so that Audacity accesses the device directly (via ALSA). I generally prefer to use the “hw” options. The disadvantage of selecting the hw option is that (usually) it requires “exclusive access” (only one application using the device at a time). PulseAudio allows multiple applications to access the same hardware device simultaneously, but also complicates the signal routing because it is another configurable software layer between the program (Audacity) and the hardware (the sound card).

OK. I’ve solved this by following the procedure at:
as far as step 4, after which it worked ok. Even produced sound from Audacity while Muse Score was still open, which is the first time ever.

Issue could be from a change in hardware, particular the audio output device. I had this problem where the audio output was being directed to a device that no longer existed.
I found that for some reason I could not change it from within Audacity for some reason as the toolbar selection was greyed out. Edited ~/.audacity-data/audacity.cfg
Now I can select from a number of devices but default works fine.

Topic closed as Ubuntu 10.04 is now obsolete.