Suddenly can't record...

First time here…

I’m running Windows 10, 2004 with Audacity 3.1.3 (had been using an older version but just updated). I’m using a Focusrite Scarlett 2i2.
After some recent issues with latency were ironed out, this setup has been working fine until today. I’ve done many multitrack recordings successfully, downloaded to mp3, etc. Suddenly, after not using it for a week, I can’t record.
I can play through the interface, monitor, playback previously recorded tracks with no glitches of issues. But it won’t record. Why?
I’ve looked at the Device settings in Audacity:
Host-MME, Recording - analogue 1+2 Focurite, Playback - Speakers (2 -Focusrite USB audio)
latency: buffer length 100, compensation -261 milliseconds
The Windows device preferences are the same…

I’ve tried both inst and air inputs in the 2i2, with guitar direct and microphone respectively. Both of which I can hear through the phones. What gives?

Probably something stupid I don’t know… Any help appreciated. Thanks in advance.

Not a Windows person, but I’ve often seen that Windows is keen on restricting permissions to use any specific microphone. This might have happened during a Windows update. Can you check that?

Hmm… A lot can happen in a week - you didn’t say if you rebooted.

re: microphone
I’ve tried different mics, plus it doesn’t record using either of the instrument inputs when I plug in different guitars. I’m hearing the sound through the headphones, including the playback of the already recorded tracks, so it seems like signal is coming from the computer back to the 2i2. e.g. I’m not just hearing the monitoring loop of the guitar > 2i2 > headphones.

re: reboot
oh yeah, many times. including with shift + restart

The USB cable is brand new. But, I guess I should try a different one?

thanks for the replies. any help appreciated