Subtle pops or clicks in my audio

Are you connecting direct? Any USB hubs or other splitters or devices?


Yes it’s the original cable that came with the mic. Desktop computer. USB connections havent changed the issue and i regularly use the ones in the back because i need the front ones for usb thumb drives ect. Yes i’m directly connected to the usb port no hub or splitter

If nothing in that link was helpful, then I’m out. We should wait for another elf.

Without fishing through the other posts, what was your other posting problem?


My other thread was about poping with my mic turned out when i cleaned it last time i had missed some dog hair ( still not sure how that go on there unless it did it dureing a recording session because i cover it when it’s not in use) and that is what was causing it. After i did another cleaning didnt have any issues with anything till this current issue.

Go back up through the thread. There’s a link to common popping notes. It’s posted out of order from Dueling Posts.


Unfortunately it dosent look like any of those are the problem. Just did another test after going down the list same problem

it dosent look like any of those are the problem

I had to try it. The other elves are nine hours that way (pointing east), so they won’t be back on line for some hours. I posted a note about seemingly generic problems with ticking.


It’s all good thanks for trying i’m sure it’s something dumb that i just can’t find

Increasing the CPU priority of Audacity to “Above Normal” is worth a shot : that lowers the odds Audacity will be interrupted by any other program on the computer …

Yes i’m aware of how computers work i’m in the process of getting my CS degree both my recording and audacity software run on high thanks anyway

i’m aware of how computers work i’m in the process of getting my CS degree

It could be argued you should be telling us what the problem is.

.06 seconds is a pretty serious chunk of time for the machine to stop paying attention to the USB data stream. That was the approx gap at the end of your sample.

I guess the question is what else do you have at super-high priority, and what happens if you lower them?

It’s powerful tempting to blame the Yeti. Yetis are responsible for pages of Audacity complaints and even a custom “Yeti Curse” filter, but I don’t think it’s the problem this time.

One Audacity note. Audacity does not apply affects or filters in real time. It always records what the computer feeds it. There is process management. You can use Timer Record. "“Wake up at 6AM and record for a half-hour.” That does happen in real time.

How well does the Yeti work on another machine? Audacity license is free. If the Yeti has troubles on two machines, The Yeti may actually have internal problems—particularly since you said the damage seems to follow your words. If they both fail, it may the Yeti or cable. If only one fails, it may be your machine.


Probably yes however i’m better at programs than i am with audio hence why i came here. I’ll try another machine see if i can find another one lying around here. Nothing else has high priority during the recordings the only thing that would be higher would be OS real time priority that i can’t change if it is the yeti i still have a warranty and can send it in

So i went and tested the microphone on another computer and it works perfectly fine the only thing i can think of now is a computer issue or the context of the room. The other room has a soft chair and rug floors where the room i record in has a wooden chair i sit in and wooden floors. I’m thinking it might be the floor stelling or the wooden chair i’m going to replace the wooden chair and lay a blanket down on the floor to prevent noise from it and see if it helps the issue.

Desperation method:

Oh, yes. That does work.

i’m going to replace the wooden chair and lay a blanket down on the floor to prevent noise from it and see if it helps the issue.

I super-duper doubt it. Wearing my pointy elf-hat for a second, the gap I found in your presentation has an 85dB noise floor. That has to be broken between the microphone and the computer, not in front of the wind screen.

After you get it running, then I’ll beat up your floors.


But it’s not the mic or the line so maybe my usb ports?

This is the file from the second computer no poping clicking different room and the computer specs are lower than mine an i5 instead of an i7 no nvida graphics card ect. Dosent seem to be the room because it was still there even when i was standing up and had a blanket down over the floor. Starting to lean towards a possible faulty usb but not all my usbs should be faulty and it happens in all of them.

Edit : After doing a little bit more investigation i did a full restart and removed background processes and did not launch steam google chrome ect i didnt hear any pops or clicks but will be doing futher testing to see if that is what is causeing the problem. Of course this shouldnt be happening with it set to high so i’m not 100% sure why it is.

Your example “test4” has a missing bit : that’s a drop-out.

Feng shui will not stop further dropouts.

Has a few mouth-clicks, (made by you) , e.g. @ ~1 second , but no dropouts.
There’s a DeClicker plugin for Audacity here, which can automatically remove mouth-clicks.

I didn’t think it was the room but i thought it would be best to check just to be safe. After a restart that was needed and the removal of non vital and vital processes it seems to have dissapperd on the computer i was haveing problems with. and i just did another test with my AV and discord open and it still worked fine so it looks like i had a bunch of shit on my RAM ect and it just needed a refreash

Constipated RAM is a constant problem.


Yeah i should of thought of the RAM when i havent restarted this pc in like a month no telling how much shit it had loaded it didnt need to have