Strange recording/playback problems


Using Windows 10, Audacity 2.4.2

I have been using Audacity without problems for may years. However now my recordings (from internet sources), whilst apparently recording ok (waveform looks normal), the playback sounds like it was recorded in a bucket at the end of a pipe.

I have not knowingly changed anything on settings. I have uninstalled Audacity and re-installed but the problem persists.

Can someone tell me what I have done?

Many thanks. John

Perhaps you are recording from the laptop microphone. Check your settings in the Device Toolbar.

Thanks for the reply.

My settings are: MME, Microsoft Sound , 2 (Stereo) , Microsoft Sound

Computer is a desktop Asus. Everything was fine yesterday.

If I load a file I had recorded earlier, it plays o/k, so I assume something on the recording side?


If you click on the Recording device and Playback device settings, I expect they will say “Microsoft Sound Mapper - Input” and “Microsoft Sound Mapper - Output”.

“Microsoft Sound Mapper” is not a real device. It is an alias for whatever is set as the default device in the Windows Sound control panel. Windows can change the default device for many reasons, without the user being aware that it has changed.

Is there an option in the Device Toolbar Recording device setting for “Stereo Mix” (or something similar to that)? If so, try selecting that as the recording device.


Thanks again for the reply.

The options I have in Recording Device Settings are: Microsoft Sound Mapper, Microphone, Line (Dell AC511 USB)


And if you select “Windows WASAPI” instead of “MME” ? …

I’m going with “MME + Stereo Mix” for now because it appears that was working previously for John.

Check in the Windows Sound control panel. Ensure that all devices in the “Recording” tab are visible (not “hidden”) and enabled.
(this article may help:

Hello again,

I looked in Windows Sound Settings and Stereo Mix was disabled.

I enabled this and then it appeared as an option in Audacity.

However, the programme will not record using this setting, the waveform is just a flat line.


Did you also check that the recording level was turned up for that device?


Yes, as per screenshot.

OK, since Stereo Mix does not appear to be working, try the “WASAPI loopback” method instead.

Well… That worked fine, all is well.

Thank you Sir.

I bow to your superior knowledge.

I wonder why it changed, I don’t remember altering anything.

However, problem solved.


Perhaps there was a Windows update.
“Stereo Mix” is a very old technology that has been gradually replaced since the introduction of WASAPI with Windows Vista.

Quite probably.

All part of the rich mysteries of Windows 10 updates.

Many thanks. John