Stops Recording After 6 or 12 Minutes

At my church, we used to use Audacity to record our sermons, but we ran into technical difficulties. It would stop recording, and give an error message.

“Error while opening sound device. Please check the recording device settings and the project sample rate.”

So I thought it might be an issue with the USB cable, I unplugged it and plugged it back in on both ends, tried a new cable, different USB ports, etc. Nothing worked.

Then one day I just decided to start it recording on a new track every time it stopped, and see if there was any kind of pattern… and there was.

50% of the time it stops after about 6 minutes. The other 50% of the time, it stops after about 12 minutes.
(I rearranged the tracks by length after the fact, before taking the below photo)

Apologies for taking a picture of a screen… there is no internet connection at my church, so I felt it was just easiest to take a photo with my phone.

The variance in lengths could simply be however long it takes me to start it recording again, which could indicate that something happens every 6 minutes that has a 50% chance of causing Audacity to stop.

I don’t know the Audacity version but I’ll find out as soon as I can. The Project Rate is set to 44100 Hz if that matters.

That sounds plausible.

Audacity does not have a 6 minute timer, so if your theory is correct you need to look for the app that does something every 6 minutes.
The Windows Task Manager may provide some clues.

There can be a couple of clues there.

We know that Skype, Zoom, Meetings, Teams and etc. take over management of the computer sound services when they run. It’s not optional. That’s how they maintain bulletproof conversations and meetings over billions of different computers.

We know that Audacity doesn’t like losing contact with its microphone—at all—and once the contact goes away, it’s forever until you reset it.


It is entirely possible that you have a sample rate mis-match somewhere in your audio stream. For example, if audio is being provided at a sample rate of 48000 and is being received at 44100 Hz, there could be a buffer overflow.

You could try simply changing the sample rate in Audacity to 48000.

Whatever rate you set in Audacity should match the rates in Windows and on your audio device. In the Windows search bar, type “mmsys.cpl”, then select the Recording tab, then select your recording device, Properties, Advanced and Default Rate. All of the sample rates should be the same.

I don’t think this is happening, but I’ll take a look. We don’t use this laptop for much other than recording, and I believe I already cleaned out the boot menu.

This sounds like a very likely solution. I won’t be able to test it until Saturday. Thank you all!

I’m also adding a couple of notes to the original post regarding the Audacity version and the other audio equipment.

I was going to add a couple of notes to the original post, but can’t find an option to edit.

I’m using Audacity version 2.1.2 (Far out of date, I’m sure, but it used to work fine with our equipment).

Our audio is coming from the USB port in the back of a Peavey PV10 sound board.

but can’t find an option to edit.

That’s not an accident. Editing old posts makes the message impossible to follow. Keep stepping through messages in the normal order. Post additional information or even a correction and just say so.

“You know two weeks ago when I said my computer was a PC with a blue cabinet? It’s actually a Mac with a red cabinet.”

At least you have a repeatable problem. The real fun comes with people that have random problems. The developers call those
“Moon Phase” problems.

There’s an easy way to split the system up. Does it still do it with the laptop built-in microphone? Disconnect the Peavey completely for this test.


Today I did a bunch of tests, and I think I eliminated every suggestion that’s been posted here.

I switched Audacity to 48000 Hz, no change.

I checked the recording devices settings in Windows, found that the Peavey sound board was set to 44100 Hz, which is what Audacity was previously running at. I changed Peavey to 48000 to match the new Audacity setting, just to try it. No change.

I unchecked the boxes regarding “Exclusive Mode” in the recording device settings. No change.

I unplugged the Peavey from the laptop and recorded using the laptop’s built-in microphone… and it allowed me to record for 20 minutes straight without incident before I stopped it.

So it’s not another app taking over the audio controls, and it’s not a sample rate mis-match. At this point I was thinking there must be an issue with the Peavey itself. I have tried replacing all relevant audio cables, with no success. However…

I tried to offset the timing, but no matter what I do, it consistently stops at 6-ish or 12-ish minutes after I start recording. When it stops I usually start it again within ten seconds. So I tried waiting three minutes instead before starting it, and it still stopped after 6 minutes of recording, not 3. So the 6-minute “timer” only ticks when the laptop is recording input from that one device.

Do you have another computer to try?

I usually start it again within ten seconds.

But not before?

If you repeatedly stop and restart at 5:30 will it record forever?

Is there any rule for when it goes to 12 seconds and doesn’t stop at 6?

There is one other test you can do with what you have. Pick up the computer and the Peavey and plug them into the wall in a different building. Problems go away, change, or get worse? Any change is valuable to know.


One more local test. Unplug the Peavey power supply at the rear of the cabinet and plug it in all the way several times. Plug the power supply into a different wall socket.

You already covered changing the USB cable.


I do. I believe I tried it last year, though, before I had time to seriously look into this issue, and got the same results. That was before I knew to look for a six-minute pattern. I will try it again as soon as I can.

I have not tried stopping and restarting it at 5:30. That would not be practical, but I can try it and see what results I get.
Unfortunately I do not have the ability to relocate the Peavey.

Okay, I’ll try that as well. I did unplug it and plug it back in once yesterday.

I do not have the ability to relocate the Peavey.

The symptoms you have are of a USB connection that periodically vanishes or loses its mind. The replacement USB cable was a good call.

Audacity negotiates a connection automatically when it starts. That’s why you have to have everything connected and settled before you start Audacity. If something happens to the connection in the middle of a performance, Audacity will not rebuild it automatically. The performance will just fail. Sometimes you can bring service back with Audacity > Transport > Rescan Audio Devices.

You can get the mismatch of sampling rates if the mixer is running at one standard and Audacity is running at another. I expect that to work, but Audacity is having to do extra work to negotiate that.

If the new computer doesn’t improve things, my guess is the USB service in the Peavey. If the music fails before the USB service, you will just get damaged sound, a glitch, or a pop or other funny noise. Not a connection failure.

I can think of two completely wild guesses about this.

Something inside the Peavey is overheating and failing, not enough to crash the mixer, but enough to cause a temporary interruption. That will give you a time offset problem. “It seems to fail every six minutes.”

The other is a lot more likely. The building wall power is ratty and you are watching power bumps when a fan, compressor, ventilator, air conditioner, freezer, refrigerator, or other heavy power user kicks on and off.

I predict [pressing fingers to forehead] the new computer isn’t going to make any difference.


Also see this forum thread: