Sterling H224 interface with Audacity

Been struggling trying to get Audio Mixer to talk with Audacity in a way where 2 separate channels will record at same time. I have latest driver for it and can confirm unit plus my computer is seeing both channels separately (1 mic and 1 guitar - signal coming from both). Audacity I think is set up the way needed from online research (record in stereo - 2 channel) but when recording, Audacity is only seeing my channel 1 and the recording is just channel 1 in stereo (in 2 places). Been trying to figure this out for a few days and running out of ideas to try. Appreciate any insight anyone might have. Thank you much.

Are you on Windows? Make sure that both Windows and Audacity are configured for stereo. More information here.

I am on Windows. I think I have both configured right - screen shot included of my settings currently. Appreciate the input.

Your settings look correct, so I dunno…

You can try Listen To This Device which works without Audacity, but I don’t know where you go from there.

Except, it looks like your interface came with recording software (Bitwig) and you can try it.

Audacity has 3 audio hosts: MME, Windows DirectSound & WASAPI.

Apparently you’re using MME,
try the other two … Tutorial - Selecting Your Recording Device - Audacity Manual

I’ve tried them all and no luck. Appreciate the input. Still researching but banging my head looking around

Try setting Audacity project-rate & the interface to a sample-rate of 48000Hz

While you’re there disable “audio enhancements” …

You rock. That seemed to work. I haven’t played around yet but I see separate tracks coming in now. I was not able to select 48000 Hz, stayed 96000 but selected 16 bit and deselected audio enhancements. Looks like it’s working! Appreciate it so much. Thank you.

This topic was automatically closed after 30 days. New replies are no longer allowed.