Stereo Track to Mono Not Working

When I have two separate mono tracks in the project and go to Tracks, Stereo to Mono, instead of beginning the conversion the program simply selects both tracks and then does nothing. I have tried various things but not yet uninstalled & reinstalled the program.

Don’t bother - that won’t do anything.

The “Tracks” menu “Stereo to Mono” converts a stereo track into two mono tracks. You want to do the opposite - convert two mono tracks into a stereo track. To do that you have to go into the track drop-down menu of the upper track and select “Make Stereo Track”.
See here for more details: Splitting and Joining Stereo Tracks - Audacity Manual

Sorry I described that wrong: I have a stereo track in which left & right are different audio streams & want to convert that into a mono track so both streams are on a single track. It always worked with my previous audacity but with this version, as I said, Stereo to Mono just selects the data and does nothing with it.

I can’t reproduce this issue and it is not a known problem.
Let’s go through the full story and see if we can spot anything out of the ordinary:

When did it last work?
Was that on the same computer?
What operating system were you / are you using?
What exact Audacity version were you / are you using?
Where did the track come from?
How long is the track?
Is it definitely “one, two channel (stereo) track” that you are trying to merge?
Anything at all that you can think of that has changed since it was working? (even if you think it not relevant).
Any other problems or “strange” things happening with Audacity?
Can you think of anything else that might be relevant?

I did another test & this time it seems to be working; maybe a glitch due to my having four tracks in all…? I will come back if the problem recurs & give more info. Thanks

OK, the problem has recurred and somehow it seems to relate to new audio files, recorded via Pamela on my new computer. Until now (and since the last time this problem arose), the only files I have been working with have been ones recorded in Audacity & not given me this problem.

To answer the questions for above: I am using Windows 10. Audacity 2.1.2

The track came from Pamela recording of Skype convo, recorded stereo with separate voice tracks. Two hours length. Combined with a track recorded in Audacity.

What I do is record my own end of the convo in Audacity, then import the Pamela stereo recording. I sync up the two tracks containing my own voice, break the Pamela stereo recording into two, and throw out the track with my voice (poor quality). I then turn the remaining two tracks into a stereo track. It is at this point that, when I go to Tracks: Stereo Track to Mono, all that happens is that the stereo track gets selected.

Is your recording mono or stereo?

How exactly do you break the Pamela stereo recording into two?

How exactly do you throw out? Is then the sole purpose of making a separate Audacity recording of your voice something to do with synchronisation? Why is the Pamela recording not synchronised?

How exactly do you do that?

We have to ask the above questions because if we can’t do exactly what you are doing then we won’t be able to find the problem.

Alternatively, you could post a screen shot of what the project looks like just before you go to Tracks > Stereo Track to Mono. Please see here for how to attach files:



My audacity recording is in mono.

I break the Pamela recording in two by going to “split stereo track.”

I throw out the Pamela track of my voice by clicking on the X in the corner of the track; the reason I do it is that Pamela does not record my voice as well as Audacity.

I turn the remaining tracks into a stereo track by using “Make Stereo Track”

Screen shot of final step:

Thanks, but I can’t reproduce anything like this following an approximation of your steps, 1 mono file and 1 stereo file, both 2 hours 20 minutes. Do you align the tracks using Time Shift Tool (F5)? I aligned both tracks to start a few seconds right of time zero.

I tried deleting either the left or right of the stereo file, but did not receive a failure.

I suggest you could exit Audacity and try deleting the files “pluginregistry.cfg” in Audacity’s folder for application data (Users<your username>\AppData\Roaming\Audacity). This means you will have to re-enable any third-party effects you have in Audacity. Please see for how to find that application data folder.

While you are there, you could also delete audacity.cfg, resetting Audacity’s main settings, but I don’t think it very likely this will make any difference.


There is no pluginregistry.cfg in that folder; have deleted the other. No change.

Perhaps the assistive toolbar sitting on top of Audacity is interfering. You could try turning it off.

Have you installed any other new software just before the problem started?

Do stereo files you recorded yourself in Audacity still behave properly with Stereo Track to Mono?

Could you download “MediaInfo” from then post the information that gives you about the Pamela files? Please get the MediaInfo version without installer, because the installer may have malware or adware.