Stereo Recording (Only One Channel Working)

I’m trying to record in stereo from my new digital piano, but Audacity is only recording in the left channel! I have two cables connected to the L and R outputs on the piano; those are then hooked up to a Stereo Y cable, which I’ve connected to the Line In on my computer. I’ve changed the recording channels from (1) Mono to (2) Stereo, and have been attempting to record, but I’ve only been getting sound in the left channel. The right channel is dead silent. Any ideas as to what I’m doing wrong? I’ve checked to ensure that Audacity is using the proper input device (which, in this case, is the Line In), but nothing I’ve tried so far has worked.

Thanks in advance for your help!

Does the plug of the stereo Y cable have two tips for stereo? Is the plug in good clean state?

If you are on Windows Vista or later (please state), right-click over the speaker icon by the system clock > Recording Devices. Right-click over the line-in > Properties. Then click the “Advanced” tab and check if the “Default Format” is a stereo choice.


Thank you for the quick response! Yes, it does. And yes, it is. I just bought it a few days ago.

I apologize; I meant to clarify that in my first post. I’m running on Windows 7 64-bit. I’ve noticed that there is a “Stereo Mix” option, but it was disabled by default. When I’ve enabled it, and made it the Default Device, no sound comes through whatsoever, not even only in one channel. I’ve now spent the afternoon working on this problem, trying everything from updating the sound card drivers to attempting to reconfigure the devices via an audio deck that came with the sound card. I’ve tested this in multiple programs as well as Audacity, getting the same problem, so now I know that it’s not the software. It’s not the cables, either, as I’ve tested them separately, and it’s not the keyboard, as I ran the outputs into a set of external speakers and it worked fine.

So at this point, I think it’s a problem with my sound card; perhaps since the “Stereo Mix” was disabled by default, my sound card doesn’t technically support stereo recording? I’m not sure…

Thanks again!

That would be expected, because the “stereo mix” device is a special input that records computer playback, and you aren’t playing anything through the computer.

Please double-check the suggestion I made which was to right-click over the Line-in (not over stereo mix), choose Properties, then click the “Advanced” tab and make sure “Default Format” is set to a stereo option. Each input has its own “Default Format”. If the Line-in’s Default Format is set to mono it could explain your issue, though most line-ins do not have a mono choice.

Then right-click over line-in again and make it default, because that is what you want to record from.

You can of course right-click over Line-in, choose Properties, click the “Listen” tab then send the keyboard audio to your sound playback device. This would let you hear the keyboard audio through the computer speakers (if that is your aim) and then you could record that audio by choosing stereo mix in Audacity. This may not record in quite so good quality, though. If you do this, you want to turn off Transport > Software Playthrough in Audacity.

Might the line-in input be faulty? Have you used it before?


Okay; thanks for clarifying the stereo mix thing!

Yes, it is set to a stereo option, and yes, in my case, it doesn’t even have a mono option. And I have since set the Line-In back to being my Default Device.

I don’t believe the line-in input is faulty. I’ve never used it for stereo recording before, but it’s done just fine in mono.

Touch the plug of your earbuds or headphones to each keyboard output to make sure there’s something there. It will not be loud, but a normal line level signal will be audible in headphones.

You are pushing yourself closer and closer to a damaged keyboard output the further you test.


No audible signal when I do that. However, I have tested both the L and R keyboard outputs separately, and they both work fine on their own. It’s only when I try to record both of them at the same time in stereo that only the left channel records.

Are you sure you have a working stereo line-in?

Here’s another real-world physical test. Disconnect the keyboard and touch each RCA center pin on the cable going to the computer. Hold the connector by the rubber or insulated jacket. Run Audacity in record and turn the record volume slider all the way up.

You are intentionally creating buzz for the purpose of testing. Watch the red recording meters. I bet only the black or Left connection works. Does the part that goes into the computer look like one of these?

Exactly the same number of rings?


Is the stereo Line-In socket blue?

The pink socket is Mic-In and it’s mono. Its sound will appear Left-Only on a stereo show.


Although on some machines the sound device might duplicate the left channel to the right channel.


Okay; I did that, and when I touched my finger to the right cable, nothing happened. Well, almost nothing. There was a slight, very slight buzz, but it was nowhere near as loud as the left. The buzzing on both cables showed up on the Input Level Monitor (but again, the right was quieter), but nothing was there as far as the actual waveform display on the track goes.

Yes, it does; exact same number of rings, 1/8 inch jack.

And yes, the stereo Line-In socket is blue.

I think you may have to try a new cable, use another line-in (for example on a USB interface) or try recording from stereo mix as I described.

What happens if you exchange the RCA cables at the keyboard - connect left plug to right output and right plug to left output? Which channel does not record then?


Yes, by all means swap out the cable and see if everything starts to run. I’m going to be Suzy Sunshine here and tell you we had a series of soundcards at work that never worked right. No matter what we did (and there’s some world-class talent in the pool), it would not record left and right correctly. We created some badly out of balance training videos and finally ripped them out of the machines and threw them away.


Okay. Currently, these are the only cables I have to work with, so it looks like I’ll have to buy a couple more.

When I change the cables around, it’s still just the left channel that records.

It looks to me like the problem is the “Stereo Y cable”. I think you may have a “splitter cable” rather than a “2 x mono socket to 1 x stereo plug” cable.

A “splitter cable” is usually used to split a single signal to two separate outputs, for example, for connecting 2 pairs of headphones to one headphone socket. With this type of cable, both of the sockets connect to the plug in the same way, so when both are connected there will still only be a signal in one channel at the plug end.