"Stereo Mix" missing from Dell Win7 64

My Dell Latitude E6400 does not have “Stereo Mix” as a sound device for recording computer playback. Yes, I have checked for Disabled Devices and Disconnected Devices and yes I updated the driver. I am using Audacity 2.0.4

I read on a blog somewhere that DELL and HP intentionally take out “Stereo Mix”. I have spent the last 2 days reading on the net/trying various combinations but the best I am able to do is record BUT there is no bass so the sound is very tinny.

I am sure I am not the first to face this problem but I could not find a clear answer on this blog.

If someone could PLEASE tell me the settings for Audio Host/Output Device/Input Device that I need to use to solve this problem I would be grateful.

Thank you!

As you are on Windows 7, the simplest choice for you is to choose Windows WASAPI host (in the first box in Device Toolbar). In the second box, choose the computer sound device you will be playing to. In the third box, choose the (loopback) input corresponding to the device you chose in the second box. So if you chose “Speakers” in the second box, choose “Speakers (loopback)” in the third box.

The loopback input records computer playback even if your sound device lacks its own stereo mix or similar input.

For full details, please read here http://manual.audacityteam.org/o/man/tutorial_recording_computer_playback_on_windows.html .


Gale this is exactly what I have been using - the only combination that works . . . . but . . . . the bass is missing and the highs are very high. Maybe somewhere else I need to tweak something else.

It would have saved time if you had made that clear in your earlier e-mail and message :wink:

Are you recording too loud? If so, turn down the system output slider and/or the volume of the player application.

Make sure the Audacity project rate (bottom left) is 44100 Hz.

What stream exactly are you trying to record? Does that have the wrong EQ as well?


The issue is not of high playback volume the output has very little bass and the treble is very high and shrilly. I even went to EFFECT and made sure that the Bass/Treble and Equalization are all at zero. I am sure it is something simple either in Audacity or one of my computer system setting which is causing this.

I have Audacity loaded on a desktop with Win7 (different version) and everything records okay. The only difference is that the desktop has Stereo Mix and the laptop does not. Does not having Stereo Mix make a difference?

I was hoping someone from Audacity would be able to help. It seems like a pretty straight forward issue for them but for low level users like me who only record the sound from the computer without using any other feature it is a challenge.

Oh yes the project rate is 44100Hz.


That would not make any difference unless you were actually applying those effects to the audio after you had recorded it.

Audacity does not apply EQ to streams as it records them.

Please tell us what stream you are recording in what web browser and whether the stream sounds shrill (a) while you are just listening to it (b) while you are listening to it as Audacity records it.

Please note you require permission from the copyright owners to record copyrighted streams.

Please check in Windows and your sound card control panel that all sound effects and enhancements are turned off. Please see http://manual.audacityteam.org/o/man/faq_recording_troubleshooting.html#enhancements .

The WASAPI recording method you are using is similar to but not identical to stereo mix.

If the problem persists after checking the settings requested, please attach a sample WAV file of the audio as it is immediately after you recorded it. To do this please see https://forum.audacityteam.org/t/how-to-post-an-audio-sample/29851/1 .


Hi Gale,

Sorry. Did not realize that you were part of the Audacity team. Great.

Gale I said in my note that either I am picking the wrong selections in Audacity or some setting in Win7 needs to be tweaked. I am sure that there are no issues with Audacity it just how does one set up the environment to make this work and I am sure others have had the same problem and have solved it somehow so I am hoping someone on the forum would show me the errors of my ways.

Thank you!

Please try the suggestions that Gale made in his last post.

Hi Gale/Steve,

I have checked all settings on Win7. I am attaching a sound clip. I have used a Youtube video to record the test - the idea being that it is something you could listen to and then judge if the recording is being done correctly. I am using Chrome as the browser.

Youtube link:

Thank you.

Which of these two files sounds most like your recording?

Hi Steve,

Finally got to get the flac files to play. Test-1 is definitely better but still not like the original - I am sure you can tell. Did you record from the link I sent you or from the file I sent?

Okay Steve what I have done is I have made 2 recordings one from the Laptop (which is the one having the problem) and one from a desktop which is fine. Both use Windows/Win7/Chrome.

Thanks for helping.

I think the difference there is just the difference between the sound cards.
The “on board” sound cards in laptops are typically made for just a few cents, so some corners get cut quite drastically, particularly on the recording side.
You can compensate for the problem to some extent by using the Equalization effect. Try settings similar to this:
Here’s a before / after - the Eq is applied after about 7 seconds:

Alternatively you could use Firefox with a YouTube downloader add-on.