Stereo Mix feedback in windows 7

I’ve just set up a laptop with win 7 and although stereo mix was present (unlike on some win7’s) and enabled nothing would record on any Audacity version. I tried as many tweaks as I could find here and elsewhere. Too many to list.

So then I fell back to the solution I discovered when my old laptop had no Stereo Mix that could be enabled…I installed Virtual audio cable. Bingo! stereo mix became available on the old laptop. And on this new laptop stereo mix would allow me to record in Audacity.

For some reason (on this new laptop but not on the old one) the volume slider for Stereo Mix (in windows mixer) gets linked to the normal system playback and I can see a horizontal line connecting across that links the two sliders together. When the stereo mix slider is raised I get echoey feedback on playback or any sound that comes through the system. This naturally gets recorded with the same echoey feedback in Audacity.

I see that others on the web have experienced this issue and despite realms of detailed advice have not managed to solve it.

My unsatisfactory workaround is to keep stereo mix disabled until I want to record and then I enable it and ensure the slider is all the way down. then afterwards disable it again

It’s an odd thing the playback volume slider is not always linked to the stereo mix slider, but after a while - hours, reboots - who knows they become linked again

Try [u]WASAPI loopback[/u] instead of Stereo Mix.

I have never seen a Stereo Mix slider in Windows Volume Mixer if that is what you mean. Volume Mixer is for output devices not input devices.

The Stereo Mix input slider should not be linked to the Device output slider. But moving either slider will affect the achieved volume level of a recording made using stereo mix.

Are you sure this laptop has correct sound device drivers supplied by the laptop manufacturer?

Have you made sure Transport > Software Playthrough in the Audacity menus is not checked?


WASAPI loopback works. Thanks doug, I’ll stick with that.

Stereo Mix
Laptop has correct manufacturers latest driver, earlier version worked no differently. Software play through is unchecked

Unless Stereo Mix slider is at zero feedback ensues . This isn’t just my issue on win7. Here’s my screen shot but someone posted the exact same thing on another forum with no resolution.

Stereo mix slider - linked to volume slider.
stereo mix.jpg

You (or someone) has enabled “Listen to this device” for stereo mix in Windows Sound. Stereo Mix then becomes a playback device which it is not supposed to be. That is the essentially the same mistake as enabling software playthrough in Audacity. The sound plays, gets recorded, the recorded sound gets sent to the output, gets re-recorded and you get a feedback loop.

To fix it, right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over Stereo Mix then choose “Properties”. Then click the “Listen” tab, uncheck “Listen to this device” and click OK.


Thanks Gale - feedback gone. Took me a couple of minutes to find the the “Listen” tab and uncheck that option because I had Stereo mix disabled and that tab doesn’t show until S-Mix is enabled.

I don’t know it got enabled? There was no feedback before I installed Vac.

Anyway, I’ve also subsequently uninstalled Vac and for some reason Stereo Mix which wouldn’t work prior to Vac now works without it.

I read that WASAPI is better quality than Stereo Mix, is that so?

WASAPI loopback should be entirely digital, as opposed to stereo mix conversion from digital to analogue and back to digital.

Depending on the device you can “usually” WASAPI-loopback record without having to hear the audio (if that is useful to you), but the recording level is fixed and is not influenced by the level of the Audacity input slider.


Got it! thanks Gale.