Stereo mix detecting sound from wrong device

I have stereo mix enabled, but it won’t record any sound. I did a test on all my playback devices and noticed that the device labeled “Speakers (Realtek High Definition Audio)” gets a response, but not my actual speakers which are labeled “Speakers (Generic USB Audio Device)”. This means that my Stereo Mix is getting sound from the wrong source, but please note I’ve also tried every combination of settings, nothing works, any idea how to change the source? Just in case, here’s screenshots of my sound tabs.

We have a damaged picture in your attachment, but we believe you.

Stereo-Mix is a service that controls the audio routing of the soundcard and its devices and systems. USB audio doesn’t go through the sound card.

One of the other elves will need to suggest a solution. Windows sound routing is black magic to me.


Sorry for the broken link, I’ll post it again just in case someone finds it necessary to view the actual image.

“Stereo Mix” enables recording whatever is playing through the device for which “stereo mix” is selected.
Thus, if you select “Stereo Mix” for your Realtek device, then your computer can record whatever is being played through the Realtek device. However, you don’t have the Realtek device selected for playback - you have “USB speakers” selected for playback, therefore nothing is playing through the Realtek device and nothing is recorded.

Well I recently figured that out, but how can I get my speakers to have sound come from the realtek thing? I don’t know how to take it off the usb speakers, I’ve tried plugging it in different places.

You need to use speakers (or headphones that have a conventional “mini-jack” connector.

The “Realtek thing” is the computer “sound card”. On a full size computer it usually has several small round “mini-jack” sockets for headphones, microphones, speakers and such like using plugs similar to this:

USB speakers don’t use the computer sound card - they connect digitally to the computer via USB.

Gah, I’m using a USB one because I’m having trouble connecting to the sound card for some reason. Whenever I plug it into the jack it doesn’t detect it, unfortunately I have no more information about that problem in specific.

Have you tried loopback recording from the USB speakers in Audacity 2.0.4 ?