static when adding opening sound


I just started editing wav files using audacity for my macbook air. I had been using audacity flawlessly for a long time on my pc. The problem I’m having is that when I add opening audio to my podcast and export the file it creates static within the first few seconds of the song. When I overlay audio at the end of my podcast this doesn’t happen. This doesn’t happen on my pc. I’m puzzled. Any ideas?


This is a know issue on Mac (and one that has been astoundingly difficult to pin down). It happens when there is “white space” (an area with no audio, not even silence) at the beginning of at least one track in a project.

The solution is to select the “white space” and do Generate > Silence into the white space.

– Bill

Can you supply the parts, clips and songs you used to get this problem? Obviously, if this is a two hour long show with hundreds of clips, then no, but if it’s a simple show and you can make this failure whenever you feel like it, you have just become a celebrity.


When I said it is difficult to pin down, I meant that it is difficult to find in the code why it is happening, and only on Macs. It is pretty well guaranteed to happen on Mac, as I understand it. I can create a project in one minute that demonstrates it. Sometimes the buzzing is loud, sometimes it is “just there” but there is definitely something strange going on.
– Bill


Can you send me one?


I can’t reproduce the problem on my Mac Mini with the built-in sound device, merely by creating any arbitrary project where one track does not start at zero. But lots of people (not everyone) have that problem on MacBook Pro and/or external sound devices and/or Mavericks/Yosemite. Moreover, it’s often said that the problem only happens if the uppermost track has white space at time zero.

In reality there are several moonphase Mac playback issues which are very hard to disentangle. I don’t even know if Bugzilla entries would make much sense. One known issue is that later Mac OS X using later Audacity often requires lower “Audio to buffer” settings in Audacity recording preferences than earlier OS X/earlier Audacity does. At default 100ms, there may be crackle or buzzing even on single tracks that start at time zero.

Do you agree, Bill, that if you get an old enough Audacity version from Audacity 2.x or 1.3.x that your playback problem goes away where some tracks start with white space?

Leland - here is the closest thing I know that is reproducible for me First 5 seconds of Export buzzing - #18 by Gale_Andrews and on to the end. Download from that topic that is an Audacity project and a WAV exported from that project.

  • I can hear the crackle in his project on my Mac Mini, but I can’t hear the crackle on Windows.
  • When I export a WAV from that project using Mac or Windows, dither on or off, I can’t hear a crackle in the WAV on Mac or Windows.
  • But I can hear the crackle on the WAV file he exported from that project (draft.WAV in the zip) on both Mac and Windows.

If we assume Audacity exports the same way on all machines on Mac and Windows, then the playback issues are highly obscure.


With my late-2011 iMac 27", with all standard drivers, I can create the buzzing, but (as Gale points out) only if it is the first track that does not start at zero. The export does not (in this case, anyway) contain the crackle (using triangle dither or no dither). Also, sometimes (but not always) clicking in the timeline to start playback after zero (but during the white space) does not produce crackling on playback.

Here’s the project:

The file “20141220 1131.aiff” in that folder is a capture of system audio during playback of the project, and contains the crackle.

The file “CrackleMix.wav” is the export from the project and does not have the crackle.

– Bill

With my “CrackleMix” project I get the crackling with 2.0.2 but not with 1.3.14.
– Bill

I get the same crackle on my new mini, so now I just gotta get a build environment set on on Yosemite…did it once…reinstalled Yosemite…didn’t bother to set up the build env again. :frowning:

Incidentally, I wasn’t getting the crackle at first. I then went into AMS and changed the output device to 48000, 24-bit integer. Then it started to happen. But, it only happens on the first play. Any subsequent play works fine.

Off the top of my head, it might be some left over cruft from the device scanning that is done at startup and that playing/stopping the device clears it.

Gonna be “fun” to track down.

Nope, that’s not it. Closing the project (while staying in Audacity) and opening it again produces the same crackle.

I’ll withhold further guess until I actually know what the heck I’m talking about. :slight_smile:

I’m pretty sure it’s caused by a mismatch in sample rates between what the hardware is wanting and what Audacity is sending to it.

Using one of the crackle.aup project above, I’m able to make the problem stop by ensuring that the sample rate on Audacity’s Quality Preferences tab is the same as what I have set in AMS for my output device.

Any difference and the problem occurs.

Again, it’s only for the first Play. All subsequent ones are okay.

And (this really sucks) I can’t get it to happen in Debug builds, just Release builds.

So, anyway, back to it…

I’ve located the cause and have a solution, but want to discuss it with the other developers before committing.


Thank you guys for all the input. Is there a way to fix this for the next program update?


I applied the fix on Dec 22, so if you;'d like to try it, grab the latest “nightly” from:



Does that mean it works for you, or are you yet to try? :wink: