static, pops and crackles using AirPods with Audacity 2.3.1 and MacBook Pro iOS 10.14.4

Audacity is recognizing the AirPods, but all playback sounds like I’m listening to the oldest possible vinyl recording played on a $4.00 turntable. How can I do my audio editing with better audio quality using Audacity and the AirPods? It’s impossible to listen/edit anything as it is now. Using MacBook Pro and Mojave 10.14.4.
Thank you!

1 Like

What happens if you use wired headphones plugged directly into your computer?

No extraneous noise at all with wired headphones. It’s clearly the AirPods and their Bluetooth platform. The AirPods work perfectly in every other situation on the MacBook Pro-- with YouTube, playback from iTunes, streaming.

Audacity does not support data compression on playback.

Due to the limited bandwidth of bluetooth, digital audio data is compressed before being sent to bluetooth headphones / speakers (similar to MP3 compression for streaming audio over the Internet).
Because Audacity is designed for high quality audio recording, playback is as uncompressed PCM digital audio.

I would have thought that the headphone drivers would handle the data compression, but your report suggests that does not happen and the full uncompressed PCM audio is being sent to the headphones. Bluetooth does not have the bandwidth capacity to handle uncompressed audio, which would account for bits of data being lost, causing pops and crackles.

What is the Audacity “Project Rate” set to? (Bottom left corner of the main Audacity window)

Project rate is 48000

Try changing it to 44100.
Any better? Any worse?

Try changing it to 22050.
Any better? Any worse?

Tried both the 44100 and 22050; the pops and crackles are still there; neither better nor worse.

How about if you drop it down to 8000? I’d expect it to sound a bit muffled, but I’m interested to know if you still get the pops and crackles.

Same crackles and pops at 8000. No change.

Perhaps it’s not related to the bit rate then. :confused:

To get back to the correct project rate settings, set it to either 44100 (the standard for CD audio), or 48000 (the standard for DVD video). The project rate sets the sample rate for exported files, so if you want your exported files to be CD standard it should be set to 44100.

Back to the problem:
You could try adjusting Audacity’s buffer settings:
“Preferences > Devices → Buffer length:”

The default is 100.
Try decreasing it in steps of 10, and test at each step (90, 80, 70 …). Does the problem get worse or better.
If it gets worse (or no better), try increasing it in steps of 10.
If it makes no difference, or only gets worse, set it back to the default of 100.

Thank you so much for the continued assistance, but changing the buffer number–either up or down–makes no difference.

Unfortunately I don’t know how to assist further, other than suggesting that you use wired headphones. I don’t use (or own) any bluetooth headphones myself, so I’m not able to run any tests at this end.

I’ll ask about this on the developer’s mailing list and report back if anyone has other ideas, but I’m not holding a lot of hope as I doubt that many (if any) of them use bluetooth headphones.

In the meantime, I’ll leave this topic open for anyone else to make suggestions.

For anyone else stumbling on this thread, I can report that increasing the buffer length (to 400ms) fixed the issue for me (Audacity 2.3.0 / macOS 10.14.4 / AirPods 2).

I have found that adopting this setting has not helped the noise problem at all. Still looking for a solution…

Changing the buffer length to 500 did it for me. Completely fixed all the crackles and weird sounds. Thank you!

Wireless headphones can give other odd problems. There’s a delay due to the extra processing and as a rule, only the computer supports wireless, not microphones, interfaces, or sound mixers. That means they can’t be used for overdubbing, sound-on-sound, and other super critical sound work.