Static for MP3

I just upgraded Audacity to 2.1.3, because I was getting nothing but modulated static, when trying to play/edit an mp3. The mp3 works fine, in VLC. After I attempt to play it, Audacity becomes unresponsive. I have tried removing Audacity: apt-get remove --purge audacity and reinstalling, apt-get install audacity, but it doesn’t help. Even with the new version, all I get is static, from this MP3.

VLC says the codec in stream 0 is
MPEG audio layer 1/2/3 (mpga)
32 kb/s

Any ideas?

Which Linux distribution (and version)?
Which version of Audacity?

How are you putting the MP3 into Audacity?

Audacity 2.1.3
Ubuntu 14.04

This problem just started and the static doesn’t occur in any other program. I haven’t done any upgrades, except for upgrading Audacity, but that was done, after the static. I even tried converting the MP3 to WAV, but it still does the same thing.

Audacity 2.1.3 does not exist, except as an unreleased alpha build. Where did you get it from - the Launchpad “Daily Builds”? You should not use those for production work, irrespective of when the playback problem started.

If you want a more recent stable release version, uninstall the Daily Builds and the repository version of Audacity and install this 2.1.2 PPA: Audacity Audio Editor and Recorder : Panda Jim.

It seems you are experiencing the common skipping/freezing problem that Audacity has with PulseAudio playback. You can probably fix it by adjusting the PulseAudio latency, or using the (hw) playback device instead, bypassing Pulse. See Missing features - Audacity Support.


Thank you.

Taken from the Audacity WIKI,

To avoid opening the terminal each time, it may (depending on the distribution) be possible to add the required latency command directly to the application launcher. If not, you can (with root permissions) edit /usr/share/applications/audacity.desktop and insert the pulse latency command directly after “Exec=”, for example:

Exec=env PULSE_LATENCY_MSEC=30 audacity %F

I had to increase to 80 MSEC, because, at 30, there was a ticking noise in all the audio.