Splitting an Audio Clip Breaks Causes ACX Check to Fail

I’m creating an audiobook using the ACX Check plugin. When I follow my process to create an ACX-compliant file, everything works:

  1. Set New Peak Amplitude (dB) to -3.0.
  2. Optionally, set Normalize RMS to -18 dB.

So far, this creates files that pass ACX Check. But now, I am attempting to split an audio clip into a new track, and everything goes to hell. If ACX tells me the Peak Amplitude is too high, then RMS is fine. If I fix the Peak Amplitude, then it messes up RMS, and I end up in an endless cycle of adjustment.

Has anyone else run across this phenomenon? BTW, if I create my file without splitting the audio clip, everything passes. Thoughts?

Are you doing production directly in MP3?
Stop that. MP3 causes permanent distortion, it gets worse at each edit, and you can’t stop it. Work in WAV files (in addition to projects if you wish) for Edit Master and Archive and make the ACX MP3 just before you submit.

Those aren’t the ACX specifications. It’s No Louder than -3dB and between -18dB and -23dB.

Instead of doing the sound processing manually, use the Audacity ACX Audiobook Mastering Macro. The Macro automatically suppresses rumble distortion, sets RMS (loudness) at -20dB (in the middle) and puts the peak value at -3.5dB.

Even better, you can apply it multiple times and you can’t hear it running.

Koz

1 Like

Think of volume like the speed of a vehicle on a journey.
Peak amplitude is the fastest speed achieved on the journey, even momentarily.
RMS is similar to an average speed over a selected distance.
If you split the journey into two halves, the average speed in the first half need not be the same as the second half, however the fasted speed attained on that journey remains the same.

1 Like

Fair warning, Mastering Macro is a text file and computers take one look at it and assume it’s a printed document and start making changes to it.

Your computer will probably try to hide the .txt part of the filename. You can tell your computer to stop doing that, or you can tell some computers to reveal the “real” filename.

Koz

1 Like

One more.

Which Audacity are you using? I was using 2.4.2 and I’m using 3.4.2 now. I don’t think this has been tested in 3.5.

Post back if you have problems.

Koz

On that splitting thing. You can’t use Generate > Silence anywhere in your chapter or book. That will not pass ACX-Check. Record some room tone and use that. You will need to record Room Tone for general production and beginnings and endings of chapters anyway.

Koz

Thank you, Koz. I don’t have a choice regarding MP3—it’s what ElevenLabs delivers on download. I will, however, take your suggestion and use the macro. I’ll report here on the results. BTW, this community ROCKS! :laughing:

DO NOT update Audacity until you finish your book. I wouldn’t update your Mac, either.

Koz

1 Like

I am using the latest version.

Are you submitting to ACX? ACX requires MP3 at super high 192 quality.

You can’t increase the quality of an MP3. Full stop.

If ElevenLabs delivers a 192 MP3, you can’t edit and make a 192 from that. If they deliver lower quality, you may really be stuck. This is from ACX.

Koz

This is a copy of their submission requirements.

https://help.acx.com/s/article/acx-audio-submission-requirements

I’m going to go make coffee now.

Koz

1 Like

But don’t EDIT in MP3. Compress to MP3 ONCE as the last step after all editing & processing.

Right! ANY linear adjustment changes the peak & RMS by the same amount. The macro uses limiting (which is non-linear) to “push down” the peaks with almost no effect on the RMS level.

…MP3 compression makes some peaks higher and some lower but since the macro is set to -3.5dB, the final MP3 rarely hits -3dB even if it goes up a bit.

3.5.0 or 3.5.1. These two have been having very serious problems with sound production stability. I’ve been recommending stepping back to 3.4.2 until they get things straightened out.

If you’re in 3.5.0, then go up to 3.5.1. if you’re in 3.5.1, you should probably stay there. Post back if you have crashes or other damage.

You thought “The Latest Version” was a safe bet, right?

Koz

I bet I can fix that.

ElevenLabs is a software company that specializes in developing natural-sounding speech synthesis software using deep learning. It has been recognized as one of the major companies behind the ongoing AI Spring.
`

Are you otherwise authorized?

Koz

I actually recorded room tone and always apply that as a separate track.

I cannot distribute the book via ACX or Findaway. I sell it on Google Play , Kobo, and my website. I want ACX compliance to ensure the audiobook meets the ACX specs.

Got it.

Were you able to get Mastering to work? You will note that even though Peak and RMS come out exactly right, it doesn’t do anything for background noise.

The last few sound tests I shot passed, but came out right on the edge of failing noise. I apply the classic two-step Noise Reduction. Step 1, drag-select some target noise. Effect > Noise Reduction > Profile. Step 2 select the whole chapter. Effect > Noise Reduction > 6, 6, 6 (which I call noise reduction of the beast) > OK.

The goal is to pass ACX Noise by a reasonable margin (-65dB, -68dB, -72dB), not to make the background noise vanish. Stiff noise reduction settings create other problems and distortions.

You can bump the first number up to as far as 10 or 12 (8.6.6, 9.6.6) before you start to create problems.

As with Mastering, 6.6.6 does what it’s supposed to and you can’t hear it working.

Koz

SOLVED. Thanks to @kozikowski , I converted the original ElevenLabs MP3 to a WAV file and did all my work in that. Then, I created an MP3 as the final output. When I did an ACX Check, it passed! Thanks to all for your help. Software, am I right?

Glad we were able to help.

Koz