Split Audio is Shorter than Video

Hi! So I’m stuck… I made a video on my phone and am trying to edit the audio but when I import the audio, it’s shorter than the original video. So, of course, when I try to put them together they do not sync. I’ve searched for a few hours now and cannot seem to find a solution. I split the audio in Audacity, OceanAudio, and VLC and all of them were right around 6:36 (though a couple were some milliseconds off…) when the original video is 6:38 so I know it’s an importing/audio issue and not exporting. Is there something I’m missing? Like a setting I need to change before importing the audio?

I have several audio tracks I’ve already edited (as I’ve done this before and had no issues previously) and didn’t realize they didn’t match up until trying to put the new audios back onto the video… And of course I’m hoping I don’t have to completely start over. So if you also know a way to stretch these in ShotCut or other editing platform, that would help as well.

The original video is 48.00 kHz and 26.20 fps.
Windows 10, 64-bit
Audacity 2.4.2. (just upgraded because I was having this problem in 2.4.1. and wanted to test it to see if that would help)

Any help is appreciated!

Effect > Change Speed is a simple speed change (dragging your finger on the record) and has the least sound damage of all the other tools. Try that.

Can you tell if the pitch of the show is too high or two low? Hope it is because that’s easy to fix.

Is the project speed at the lower left of the Audacity window 48000? It would be handy if it was.

Do you have the FFMpeg software installed? You may need that to manage the more unusual sound formats.

26.20 fps.

That’s not a standard video frame rate. Are you trying for slow or fast motion effects? That’s may be where your speed match is going.


Hi kozikowski!

I listened to them back to back and it doesn’t sound like the pitch is off, but I could be wrong.

And yes, it says 48000 in the lower window and I do have FFMpeg installed - that’s who I typically import the audio directly from the video (though I did try various ways to see if that was the issue).

And yeah, I know it’s not a standard frame rate, but that’s what my phone filmed… definitely not trying to change the speed. Maybe I need to look into that as well. It filmed that way last time too, but those imported normally. Is there a setting I need to change to allow the audio to be imported at this frame rate? Or maybe I need to convert the videos to a different frame rate and then split the audio? That would mean starting from scratch which would suck since I already split and edited the audio from 20 videos… but that sounds like something I may need to try.

I"m not sure what you mean by

Effect > Change Speed is a simple speed change (dragging your finger on the record) and has the least sound damage of all the other tools. Try that.

not sure what you mean by

Change Speed changes everything, pitch, speed, duration, all at once. The sound relationships stay constant and so this tool has the least sound damage.

The other tools, Change Pitch and Change Tempo rip the sound apart, change only some of the relationships and then try to smash everything back together. Most of the time you can hear those working. Those aren’t gentle or clean.

So if it is a digital sampling rate error, you can make a simple fix with Change Speed. Change Speed has different ways to steer it. If you know the old and new duration, you can put those values into the tool and it will resolve them. You can know the percent difference or the multiplier. “This track is 2 times the other.”

It’s worth a try. You can always Effect > UNDO if you don’t like the result.


Okay that just might work! And I won’t have to redo everything (:

Actually… it didn’t work. I changed the time to match the video and when I added both of them to ShotCut, they’re still coming up as different lengths. I set the audio to change to 6:38.05 and it shows that it did, but it exported at 6:38.01. So I tried again adding some length - 6:38.09, but it exported at 6:38.02… So I tried again setting the length to 6:39.05, and it exported at 6:39.01. I’m so confused now. I’ll test a few other lengths to see if I can find a matching length, but this is quite annoying.

I did just realize that the 26.20 fps was for a different messed up video… this one is actually showing 19.27 variable… I have no idea why my phone does this… I filmed these two videos back-to-back and frame rates are so different.

Ok, so I messed with it a bit more, and it looks like the 6:38.01 actually fits the best out of all of them, but I have to move the audio over to the right to match the video. But… when I do that, it eventually gets off track by a few ms. It’s not terrible, but I’d of course prefer the audio to match exactly as it is a face-to-camera video and I’m talking and demonstrating the entire time.

Sorry… one other question. If Audacity and OceanAudio and VLC all came up with the same audio lengths on import… what is the standard frame rate at these would use? I can’t seem to find this information. I’d like to see if I can adjust the frame rates of my videos and see if that matches the audio files I’ve exported. Is is maybe 24 or 30?

European video rate is generally 25/50. US can be 30/60. Film rate is 24.

The legacy rates in the US are 29.97/59.94 from back when we were struggling to get analog color TV to work and 23.976 for combining film and legacy US TV. You may still run into older videos that don’t mix well with your newer stuff. This can be why.

Are you describing a six hour video? Depending on how you shot it, you can get that kind of error by simply shooting with two different cameras. Home video shoots were never designed for multi-camera.

When the grownups do it, their cameras are certified to run for like days without going out of sync. Same with separate sound. You can’t shoot an action movie with a cable between the camera and the sound people, so they all have to maintain stupid-accurate sync all the time.

If you shoot the exact same scene with two phones, I bet they don’t match.


Ok I thought that was the case with the frame rates. But no, I shot these videos back-to-back on the same phone - only 6.38 minutes long. BUT I did end up converting the video to 30 fps with Handbrake and when I import the audio now into Audacity (and others), it’s now showing the matching length…

So that’s good that I found something that works… but sucks that I have to redo all the audio editing of 20 4-7 min videos :confused: Man that’s gonna suck. I was really hoping to avoid that. Oh well. Learned something new I guess.

Thanks for the help!

I think this is sometimes caused by corruption in the original audio/video file (maybe something related to MPEG time codes) but for some reason everything stays in sync until you edit. It seems to be more common with the highly-compressed formats such as MPEG-4 or H.264 but I’ve had it happen with MPEG-2.

I have an (outdated) application that can repair time codes. VideoReDo ($50 USD and up) is also supposed to fix sync problems. Or, sometimes re-encoding to a different format (or a different bitrate) will fix it.

The trick seems to be repairing or re-encoding the original file before the sync problems show-up. Of course, you’d like to avoid re-encoding lossy audio or video but it may be necessary to fix a problem. Your video editor can re-code or you can use [u]Xmedia Recode[/u]. If you can make a “repaired” A/V file with uncompressed audio (which Xmedia Recode should be able to do) the will save the audio from unnecessary generations of lossy compression.

Note that MP3 (and maybe other lossy formats) add a few milliseconds of silence to the beginning of the file. So it’s best to export to WAV then let your video editor re-compress the audio when you export the combined audio/video file. (It’s probably going to re-compress even if you feed it a compressed file.)