Spitfish Plugin Not Working

I have Audacity 2.0.5 installed on windows 8.1 (64-bit) using the .exe installer

When I try to use the spitfish plugin I either get no sound at all or I get a piercing high pitch sound. I’ve tried to adjust the knobs and reinstall it but to no avail. Ideas anyone?

Audacity does not make Spitfish, but it does work with Audacity. Have you tried reading the Fish Fillets Manual?

The SPITFISH detects ‘essing’ by being tuned to the most badly sounding region. To find out about where this is, press the ‘listen’ button. You will probably hear… nothing. This is okay, since you are listening to the signal in the same way the control circuit would get it.

In order to hear anything, you have to increase the ‘sense’ level until there is anything to sense at all.

The reason why you have to adjust something here is that you need to tell the device what’s the most prominent level at where ‘essing’ is most likely to occur. Turning the ‘sense’ knob fully up means maximum sensitivity. You can compare this to a very low threshold on a classical compressor, though it’s not quite the same.Typically, you should adjust the level in a way that normal sounds don’t let the meter instrument light up while ‘s’-like sounds trigger it as far as possible.

To achieve such maximum difference, unpress the ‘soft’ button. Now the unit is running in some sort of ‘hyperactive’ mode. Now, the actual amount of de-essing can be adjusted via the ‘depth’ knob. This controls the level of a band-cut filter tuned at the center frequency of where you set the detector at. Whenever SPITFISH is behaving that sensitive as described above, you only need to dial in a small amount of ‘depth’ in order to achieve serious de-essing.

If it sounds too drastic, try using the ‘soft’ mode. This switch adjust the internal time constants to a slower behaviour and feeds the detector with a softer transition curve that rules over ‘no’ signal and ‘fully essing’.

Have you tried http://sleepytimedsp.com/software/lisp instead?


I was able to get it working by disabling the GUI by going to edit>preferences>effects and unchecking the graphics interface.

I don’t believe that’s anything to do with it all, assuming you obtained Audacity from us (http://audacityteam.org/download/windows) . I tried Spitfish in Graphic mode before answering.


I’m having the same issue with spitfish. It seems to be installed correctly and blockfish works just fine. I’m assuming that when I click “listen” with the knobs “sense” and “depth” turned up, that I should hear my loaded file play. It doesn’t. When I click “preview” with the knobs set in any configuration, the file plays for a few seconds but with no discernable difference with any setting. I’m also running Windows 8.1. thanks JIm

Please see my previous reply https://forum.audacityteam.org/t/spitfish-plugin-not-working/34382/2 . If you have material that Spitfish is capable of working on, it works correctly - I just tried it. You won’t hear anything with the effect open unless you press Preview. You can set a longer preview at Edit > Preferences… then the “Playback” section.

Try Lisp instead.


I’m using Windows 7 Professional, Audacity 2.1.0 and I obtained the Audacity zip.

I’m using the Spitfish de-esser and when I click on play from the Spitfish plug-in, it works. But after I hit apply, nothing happens. So I close Spitfish and see if it made a difference by playing again from Audacity. Nothing changes. I still hear the original sound. I only hear the improved sound from the Spitfish plug-in.

Can you help? I already tried reinstalling Spitfish, and that didn’t work.

Thank you.

There is no bug with Audacity that I can see. “Apply” applies what you heard when you pressed Play in Spitfish.

You may find it useful to read the Spitfish manual included with the plugin.

Or try LISP instead: http://sleepytimedsp.com/software/lisp.