spitfish and de esser is not showing up on audacity

I’ve downloaded spitfish and other de esser plug ins and followed all the directions but when I finally go to audacity then go to edit-preference-effect and all the boxes are checked but nothing happens after clicking ok. I’ve try to go to add/remove plugins and it’s no where to be found. Is there something missing in my computer that’s making it so it doesn’t work?
any help would be great. I’m about to give up trying but I really need the de esser.

You don’t actually have to find them.

Show: All > Select All > Enable > OK.

That should activate everything.

De-Esser can be a little odd to use.

Post a sound clip with sibilant examples.


Did you need sibilant repair before you applied effects and corrections to your voice?


If you put the plugins (unzipped) in the Audacity plugin folder they should be visible.
You have to enable the plugin before it appears on the effects list …

I did both the suggestions and it’s already enabled and the spit fish is still not there…
I forgot to mention I had to make a VCT folder since it didn’t have one. Do i need to put anything in there?
I feel like this laptop is missing stuff…

I’ve also manually put in audacity but it says audacity does not recognize the file, need to download ffmeg or import raw data, i tried the import raw data and it does something totally weird.

If you are using the latest version of Audacity, the plug-in (VST) folder has moved from “Program files” to this hidden folder