Spinning beach ball

I am having the same problem and can’t even Control/Alt/Delete to shut it down. Get the spinning beach ball. I just downloaded Audacity today for the first time (can’t see which version because Audacity isn’t responding but it is TODAYS version). Just imported my first audio tracks. Saved the project and was going to shut down my computer but can’t get the debug report window to go away.

I am using Mac desktop 10.12.6 and Sierra. Help.

What do I do? Why did this happen?

UPDATE: 4/10/20 - 10 am: I opened Audacity up this morning, after clicking in the audio track and going to the menu bar, the debug report preview came up again and froze everything. The beachball never goes away. I can’t click in the menu bar and cancel doesn’t work either. I have to do a hard shut down on the computer and start it up again to get my computer back. I cannot use Audacity. Please advise me what to do because I can’t use it at all. Thank you.

Which version of Audacity?
Did you get Audacity via the Audacity website? (https://www.audacityteam.org/download/mac/)

How did you open Audacity?

The spinning beachball is pretty serious. That’s from the Mac, not Audacity. That means the Mac is taking way longer to do something than the time allotted.

When was the last time you shut down your Mac? I don’t mean Apple > Restart, I mean full shutdown. While it’s going down, do you get a tiny spinning daisy on the screen? Does the daisy hang for a really long time? One or two seconds is reasonable. If the daisy hangs, your Mac was choking either on a job (or jobs) or running out of memory or drive space.

Macs don’t make a big fuss about actually closing apps when you’re done using them. They just nap in the Dock (little light under the APP) and eventually, the system runs out of room. Do you use any Adobe products? They’re becoming famous for viciously defending what they perceive to be their licensing rights—to include shutting down your machine.

There may be a more obvious problem. How long was your show? Audacity doesn’t make a very good surveillance recorder. It used to actually stop working at 13 hours. I don’t think it does that any more. That’s hard for a machine to deal with. Audacity works with sound in a really high quality format and the storage fills up faster than you think.


I got Audacity from link you have there and followed those instructions (I am not techy so I had that open in another tab on my screen so I could follow exactly what the directions for downloading were - which was something like: It downloaded to my downloads folder, I dragged over to applications. And, opened by clicking on it in applications.) I used it right after downloading and it worked great, even follow directions for the FFmpeg so I could import audio file from zoom recording. Did that and it worked fine. I also brought in some music. Did some editing. Saved it. Then, when I went to menu bar to start to close it, the debug report came up and it froze. I walked away for a while thinking it was working on something. Came back 10-15 minutes later and it was still on screen. I couldn’t cancel or quit Audacity - only got beachball. I came here to search for answers, posted my first message. Finally had to do a hard shut down on my computer because I couldn’t cancel or close anything or control/alt/delete or quit etc. Turned it on this morning, went to my applications folder, clicked on Audacity icon, it opened up, I opened up the file I was working on yesterday and within just a few minutes that same debug report box opened and again same thing, couldn’t cancel or close or quit. I finally had to do another hard shut down of my computer.

It looks like lots of other people have trouble with this debug report freezing. Is the problem resolve-able? Or, should I move on? Is there something I can do to get Audacity to work on my Mac? And, since this seems to be a problem for people, and if we are doing something wrong with install or use, maybe we should have that info added to the downloads page to prevent this from happening for other people. I hear such great things from people about Audacity but only got to use it 1x before the debug report came up and froze everything.

I do hard shutdowns regularly. I only downloaded the program for the first time last week, so have the most recent version. I have plenty of space for it. Haven’t had this trouble with any other app (Mac ‘thinking’ so long and freezing). Not sure how to proceed.

Should I uninstall everything and try again? Will I still be able to import the work I started? What do you suggest? Thank you.

Oh, forgot to mention. My show length was only like 25-30 minutes.

Got frustrated waiting, so I uninstalled it. I made sure there was nothing in the ~library/Application Support (?something or rather) then I reinstalled and opened the recovered file I was working on.
At first it said: Warning: Problems in Automatic Recovery - Project check found file inconsistencies during automatic recovery. Select ‘Help > Diagnostics >Show Log…’ to see details. I did that: That shows where the FFmpeg libraries loaded successfully. Then 6 WARNINGS.
The first 4 warnings: Orphan block file…then the file name.
The 5th warning: Project check ignored orphan block file(s). They will be deleted when project is saved.
The 6th warning: Project check found file inconsistencies inspecting the loaded project data.
I closed that box/window.

The file I had been working on was on screen. I noticed the audio file was zoomed way out so I zoomed in on it. Then, this message appeared on screen: SamplingTools need to take control of another process for debugging to continue.
It wanted me to enter my admin password, instead I hit Cancel.

Then: Developer Tools Access needs to take control of another process for debugging to continue.
It wanted me to enter my password and instead I hit Cancel.

Then, the Debug Report came up and the eternity long beach ball that doesn’t allow me to Cancel or close or Quit Audacity. It just stays there forever. I have to do a hard computer shut down to make it go away. The debug report has been generated in the directory:
“//var/folders/10/zhxmfg1 1 1tj6nxt8tt5q9_xm0000gn/T/Audacity_dbgrpt-1976-20200413T143122”

So what do I do now? I can’t use Audacity at all like this. :frowning:

What did you drag over to applications? The DMG file?

I downloaded it, it automatically went to downloads, I clicked it once and it opened up a window that looks like the one in this YouTube where you simply click on the file and literally drag it to a folder called Applications (looks like a shortcut), just like in this video.

Desktop > Go > Utilities > Activity Monitor.

I leave the app down in my Dock along with other programs. I run it when I think there’s something funny going on. Several times I found a stuck or mis-directed application or process taking up 99% of the machine.

We are warned against “Plenty of Room.” Go > Computer > Right Click Macintosh HD > Get Info. Shift+Command+4, draw a box around the General info panel and post the picture.


Is Audacity in the Dock?
If it is, try right click on the icon, and select “Open”. Does macOS show any warnings or other message when you do that?

For some reason the paste, doesn’t work. I copy pic (I’ve done that before but doesn’t let me paste it here)
Capacity: 499.25 GB
Available: 103.97 GB
Used: 395.28 GB

I have 103 GB available, isn’t that enough?

Yes, it has an Automatic Crash Recovery box that pops up: Some projects were not saved properly the last time Audacity was run. Fortunately, the follow projects can be automatically recovered: and then it lists my project name (the first and only one I have) Then at bottom it says: After recovery, save the project to save the changes to disk.

The last time this came up, I hit recover projects. Then it bring it up. But, then a warning box pops up: WARNINGS: Problems in Automatic Recovery Project check found file inconsistencies during automatic recovery then select Help>Diagnostics>ShowLog I hit OK (If I try to do that, SHOW LOG isn’t highlighted so I can’t do that.) so I hit OK. Then, I can get to my project. At this point, I can edit the audio track I have, save project, close Audacity; reopen Audacity and select my project and work on it again. HOWEVER:

I think it is happening whenever I go into and click on the music track (an m4a file of royalty free music). If I have the music track muted and just listen to my audio (me talking) and edit and save it and have only clicked in that audio track, everything is fine. I can close it and reopen and work on the audio track. But if I click in the music track then, the box pops up that is the SamplingTools needs to take control of another process for debugging to continue. (I have to enter my admin password) and this is where it all repeats with the debug report and beach ball. Then, I end up having to do a hard shut down. This time I had the activities monitor on and under the tabs in activities monitor it shows Audacity in red and NOT RESPONDING - in every tab.

If I enter my admin password and hit enter then the debug report preview shows up. Activities monitor under every tab still shows Audacity in red and NOT RESPONDING.

So roughly 20% of the drive is free. That’s good.

You usually can’t paste directly on the forum.

Attachments (under a forum text window) > Add Files > Select the file.

You don’t have to post anything. You’re looking for something getting stuck at an unreasonably high usage. It doesn’t have to be Audacity.

We’d be looking for anything that Audacity is not expecting. Are you using Google G-Drives or other on-line storage?

Do you have a Skype, Zoom or other on-line session running while you work? Games? Are they napping in your dock? Audacity is competing with something for system resources.

(an m4a file of royalty free music)

Is this a music service that keeps checking back to the home office as you use it? I have some of that. That can create all sorts of problems. Can you disconnect your network as you work? WiFi? You can turn that off with the fan symbol at the top of the desktop. This is WiFi off.

Screen Shot 2020-04-16 at 15.53.50.png
Does some app or service go nuts when you do that?

As above, complaining about the debug report is like complaining about the newspaper reporter at the factory fire.