speeded up recording from mic problem

Using Audacity 2, everything I record using a mic gets recorded in a speeded up way, like cartoon voice. I looked everywhere in the GUI and in forums, getting no solution.

Help, please.

Describe the mic. Model numbers? Koz

Olympus TP-7 specs:

I had this mic recording fine a week ago using settings:
Audio Host: MME
Output Device: C-Media PCI
Audio: Wave
Input Channels: 2 (Stereo) Input
Audio Host: MME
Output Device: C-Media PCI Audio
Input Device: C_Media PCI Audio: Stereo or :Microphone
Input Channels: 2 (Stereo)

Tried every combination of these four settings today, always speeded up playback and same in the saved file, but in the past hour it’s also now echoey.

I hear my live voice signal perfectly through the PC headphones, no distortion of any kind.

As I say, this worked fine last week.

Win XP Pro SP3, 32 bit.

adding to my post above:

If it means anything, I notice the moving blue vertical progress line during recording moves somewhat slower than it moves during playback.

The echo could be coming from your built-in microphone. Are you recording that instead of your USB device, or are you recording Stereo-Mix or other service? Set with the Device Toolbar.

Recording internet audio or built-in audio settings are different from recording a live guitar or voice.



There is no device plugged into my USB ports. I have tried all different combinations of Input and Output Device in the dropdown lists. The settings in my first post produced perfect voice recordings using TP-7 last week.

I think everything’s OK now after much digging around. I went into the sound card controls and found that an echoey room effect had been applied, though I have never touched this interface before in the life of the computer. It must be because of a major crash of my PC three days ago where even the internal clock was reset to 2007, the year the PC was made.

So, I undid the sound card echo effect. Now, in Audacity, the recording progress is not laggy like before and playback is normal speed (and, no echo now, of course). I am guessing this old and very weak computer simply could not keep up with the application of the echo effect, therefore making recording in Audacity sluggish. Before I found the sound card echo effect had been applied, btw, I adjusted the Audacity Tempo in Effects to minus 48, so that my recorded voice sounded like what I believe is normal tempo. That Tempo effect adjustment is no longer necessary since the sound card echo effect was disabled.

I am building a new PC, needless to say.

My settings that are working for the Olympus TP-7 are:
Audio Host: MME
Output Device: C-Media PCI Audio
Input Device: C-Media PCI Audio: Microphone
1 (Mono) Input Channel

I’m having the same problem. Can you please tell me how you got to that setting?

I use a TP-7 to record telephone conversations all the time for when someone starts giving me rapid-fire long lists of instructions. I used to just miss them all.

“OK, What now? Sign the blue form and put it in the purple envelope and send it to Chicago?”

I’m using a StarTech ICUSBAudio as the microphone amplifier, power supply and digitizer. It arrives in the computer as C-Media USB Headphone Set. That must be the chipset and maker.

I’m also using a Mac laptop which has no provision for external Mic-In.

Performances speed up when they’re recorded slow. When the computer can’t keep up with the work, it starts dropping sound samples or other data. Those shows always play back fast. It’s like slowing down a move camera (undercranking) so the movie appears speeded up in the theater.

Note nobody ever complains of a slow performance.

Anyway, if you’ve had the machine forever, you need to deal with all the things Windows machines do when they’ve been on-line forever. Choked Registry, full hard drive, fragmentation, etc. etc. All can slow down a capture and cause a damaged data stream.