Spectral edit parametric EQ error

OK. I installed 2.3.3

Spectral edit parametric EQ is in the Effects menu

I’ve enabled Spectral selection in the track Spectrogram and selected the frequency range for the effect to act on

Restarted Audacity to see the settings are there


I still get the same error message …when I try to use the effect

'To use ‘Spectral effects’ enable ‘Spectral Selection’ in the track spectrogram and select the frequncy range for the effect to act on.

Does anyone have any clues?

Are all selected tracks displaying the spectrogram, and is there a “spectral selection”?
(see: Spectral Selection and Editing - Audacity Manual)

You get that error message when the waveform is shown rather than the spectrogram …

spectral edit only when in spectrogram view.gif

Thank you guys

I’ve got 2.3.3 with the spectrogram plugin enabled

I can switch to spectrogram view on the track I want to edit

But the Spectral EQ option doesn’t show in the Effects menu anymore

Have you disabled “Nyquist effects” in the Audacity Preferences? (Effects Preferences - Audacity Manual)

Ah ha!
Nyquist disabled on one machine and not the other - with me thinking that it was enabled by default when a new version is installed

Such is the joy of installing newer versions

Thank you

On Windows, updating Audacity will preserve your settings unless you select the “Reset Preferences” option during the installation of the update.

Thank you for all the answers but I’m still trying to get Spectogram to work

Even though the settings are correct I think. I still get an error message telling me I need to change the settings

That’s because your track is showing “Waveform” view.
Click on the track name, then from the drop down menu select “Spectrogram”. You will then be able to make a selection that has both a time range and a frequency range like this:

See here for more information: Spectral Selection and Editing - Audacity Manual