Soundflower 1.66b does not appear in El Capitan [SOLVED]

I recently upgraded to OS X El Capitan on my iMac desktop computer. I had been recording Internet streaming audio with Audacity 2.1.1 and Soundflower, receiving excellent results. Since the upgrade, Soundflower has disappeared. It no longer shows up when I open System Preferences/Sound. Also it does not appear in the Audacity input window. All I see is Internal Microphone. Audacity records the streaming audio without Soundflower, something that previously could not be done; however, the sound quality of the recording is very poor. Can anyone advise me as to a fix for this problem?

Maybe this will help?

This article has info for updating Soundflower for El Capitan

Thanks, tubegeek. Yes it seems that the Soundflower 1.66b supplied by RogueAmoeba which we link to in Tutorial - Recording Computer Playback on Mac will not appear in El Capitan. This is because 1.66b installs in System/Library/Extensions but El Capitan requires installation in /Library/Extensions.

For those not wanting to pay for iShowu, I suggest downloading Soundflower-2.0b2.dmg from If there are problems, you could follow the instructions further down that page, but those instructions assume you are comfortable using the terminal.

What I would suggest to try to avoid issues is to open the /Applications/Soundflower/ folder, double-click “Uninstall Soundflower.scpt” then in the window that opens, press the “Run” button. If you see “Done!” in the results, the script completed OK. Reboot the computer. Then run the “Soundflower-2.0b2.dmg” installer as above.

I’ll report back later how it works for me on El Capitan. The Manual will need to be updated when we figure this out (P1).


I did this process exactly. It works. No iShowU needed. Opened Audio MIDI setup and I have 2- and 64-channel Soundflower selections available.

Assuming you ran Soundflower-2.0b2.dmg from, did you get a “Soundflower” folder in /Applications? I don’t, so although I get the 2-ch and 64-ch Soundflower devices in System Sound Preferences, Audio MIDI Setup and Audacity, and can record fine in Audacity, there is no Soundflowerbed included. So to hear what you are recording it is necessary to enable Software Playthrough in Audacity, and Soundflower is not viable as a general output device.

That said, Soundflowerbed from the 1.66 Soundflower installation works fine with Soundflower 2.0b2.




I didn’t get too far into it yet, I will file that info away for future reference - thank you - but I have nothing to add here.

Thanks for all of the advice and help. I followed instructions and downloaded the new version of Soundflower. Audacity is now working just like before and I can record my weekly meeting audio once again. :smiley:

I too downloaded the later version of Soundflower. Uninstalled the prior version and updated the current version. Soundflower now shows up in sound preferences and Audacity is working again. Thank You Thank You Thank You


I’m trying to get Audacity (2.1.0) and Soundflower to work the way they did before I installed El Capitan.
I’ve deleted the old version of Soundflower I had and installed the version in Soundflower 2-0b2.dmg.
I can now see 2- and 64-channel Soundflower selections available in Audio MIDI setup.
I’ve made a multi-output device and an aggregate device linked to the Built-in Microphone, Built-in Output and Soundflower (2ch) and tried various combinations of these as the default input and output devices via System Preferences > Audio.
I’ve tried linking Audacity to Soundflower.
But whenever I try to record something, all I get from Audacity is an Error message saying “Error while opening sound device. Please check the recording device settings and the project sample rate.”
The only way I can get Audacity to record and play back anything is by linking it to the Built-in Microphone and Built-in Output (which works even without any version of Soundflower installed). And although this does work, the sound input is through the Build-in Microphone so the quality of the sound from other applications is poor.
Any ideas??

What are you trying to do, exactly (why do you want to create multi-output and aggregate devices)?

What devices are in the multi-output device?

Have you installed Soundflowerbed?

Soundflower works in El Capitan if you don’t create multi-output and aggregate devices.


I just want to be able to make Audacity files of whatever I can hear coming through my in-built speakers - but which sound identical to the original sound when I play the file back.

The Audacity files I used to be able to create did sound identical to the sound as it had originally sounded when coming through the in-built speakers. When recording an Audacity file, any ambient room noise wasn’t picked up at all - the Audacity file was clearly not receiving it’s input from the in-built microphone…

Since installing El Capitan, I can still record files with Audacity, but the sound that’s recorded is that which is picked up by the in-built microphone. The sound that is recorded therefore includes the sound coming out of the in-built speakers + any ambient room noise.

The multi-output and aggregate devices are a red herring - I thought they might be helpful, but clearly not. I’ve deleted them, and the problem continues to be the same as it was before I created them in the first place.

I’ve tried tuning Software Playthrough on in Audacity, but that just makes things worse.

I don’t think I’ve got Soundflowerbed installed (I just followed the instructions for installing Soundflower-2.0b2.dmg set out above). I note that you said further up this post that “Soundflowerbed from the 1.66 Soundflower installation works fine with Soundflower 2.0b2.” - but how would I go about extracting Soundflowerbed from the 1.66 Soundflower installation?

It “should” work without recording anything else if you select Soundflower 2-ch as the system output device, as system input device and as the Audacity input device.

Software Playthrough should be off when recording Computer playback by any method.

Soundflowerbed is not necessary to let Soundflower record, but lacking Soundflowerbed will mean that you cannot hear what you are recording.

The best thing is to copy to your Desktop or somewhere else before uninstalling the old Soundflower.

If you no longer have then it’s messy, because there is no simple way to extract it from the 1.66b Soundflower package at without reinstalling the old Soundflower.

What you would have to do is download the shareware Pacifist app. Mount the 1.66b DMG then use Pacifist to extract from the 1.66b Soundflower .PKG package.

Or, use pkgutil at the command-line to extract from the 1.66b .PKG.

Anyway, to make life a little simpler, I’ve attached here.

Gale (90.7 KB)

That’s fixed it! Thank you so much Gale - massively appreciated.
Best wishes

Excellent. Given we seem to have a clean method worked out, I will mark this [SOLVED] and lock the topic.