Sound quality issues when recording over pre existing tracks

Hi! I’m still fairly new to the program, but just came here to ask about a problem I’ve been having. I’ve been recording with Guitar and vocals, using the Focusrite Scarlett solo, which has so far worked great for me most of the time. Both recording guitar, and recording vocals with a Mic sound great on their own, but when I try to record vocals when there’s already a guitar track, the recording sound quality from the Mic suddenly gets inexplicably grainy and has terrible sound quality.
This only happens with the Mic, and it only happens when there’s already a track that I’m recording over, even when the other track is muted. Any thoughts? Thanks!

Can we say this a slightly different way; it only happens when you have Overdubbing selected?

– Audacity > Edit > Preferences > Recording > [X] Overdub… should be the only thing selected.

This is an odd overdubbing problem. Past the people who get it to work first time out of the gate, the usual problem is Overdubbing Pileups. Each overdubbing pass records you and everything that came before.

I can’t generate a good cause for your problem, particularly if you muted the original track and it didn’t help a bit.

You can record your voice normally, right, not in Overdub?

Select ten seconds of the distorted vocal if it’s stereo and 20 seconds if it’s mono > Export WAV (Microsoft) and post it here on the forum. Scroll down from one of these forum text windows > Upload Attachments > Browse…

Is it still distorted if you play it in QuickTime or iTunes—not in Audacity?


Here’s the 10 second clip. In preferences > recording, overdub is the only thing selected. Yes, without any overdub the audio on the Mic is totally normal. And yeah, when I export it the weird graininess stays. The weird part is, very occasionally, I will record it and it will be normal but more often than not I have this problem and it seems to be totally random.

You have straightforward small “dropouts” it seems, where nothing is recorded.

This is common on later OS X with Scarlett devices unless you run them in “class-compliant” mode. See this advice from Scarlett

If that doesn’t help, then probably you need to open /Applications/Utilities/Audio MIDI Setup and set the Scarlett Solo sample rate for both input and output to the same rate you are using in Audacity (which currently is 48000 Hz according to the file you attached).