Sound Device Setup - M-audio Delta 66 [SOLVED]

The system is: Dell Optiplex 755, 4 gig ram 64 bit, Running Ubuntu 14.04 64 bit version

Most people who run linux know alot about it. I don’t. I’m just now converting.
I am not getting sound. No sound devices show up on the on the ubuntu settings control panel.

However they do show up as devices on Audacity. They also show up on the ALSA mixer
There is no sound, There is onboard audio but it doesn’t show up either.

I can plug in a usb interface and get sound with audacity. It doesn’t show up in the system,

An M-audio Delta 66 audio interface is what I need to get working. I have heard that it is a little tricky to get it set up.

This might mean Pulse Audio is broken. Pulse Audio is the system audio mixing device (oversimplifying it).

Sometimes installing Pulse Audio Volume Control (pavucontrol) can help, or you may want to reinstall Pulse Audio itself.

Open a terminal and type:

sudo apt-get install pavucontrol

If you need to reinstall pulseaudio, see . I think that still applies to Ubuntu 14.04 except that there is no reinstall command. Type sudo apt-get --help to see the available commands.

About M-Audio Delta 66 see and - you may want to install alsa-tools to get the Envy24 mixer panel.


Gale, thanks for helping.Sound is showing up on ubuntu, below. The Delta 66 is not showing up as a device on Audacity even though it was previously. Should I start a new thread just for thee Delta 66? I could not figure out what to do with the information on the m-audio link you provided. That is my fault because I do not know many terms or even the names of programs I need.

Good. What did you do to make that happen?

Do the inputs show in Ubuntu too?

Have you tried Transport > Rescan Audio Devices in the Audacity menu?

Did you install alsa-tools ?


All I did was use the sudo command you gave me. Inputs show up also. All devices show up in audacity after restarting. Only the alesis usb device works. It is still hard to get sound in most programs. Sometimes running a program, for example band in a box with wine, changes something and sound stops working other places.
I have not installed alsa tools. I didn’t know there was such a thing. The only ways I know to install things are of off the ubuntu software page or with the terminal. With the terminal all I have ever done is cut and paste code. I have no idea how or why it works.
All of the devices show up on the alsa mixer but nothing lights up. Basically I don’t know what programs I need to install or how to instal them if they are not part of ubuntu’s software bundle.

You mean if you a play a song in other audio software, you may not get sound even if you select the built in audio output in pavucontrol?

If it’s as bad as that I would consider reinstalling pulseaudio (see the instructions link I posted).

I would get built-in audio and all external audio devices working with built-in Ubuntu applications, before worrying about Band in a Box. WINE does not work perfectly with all Windows apps.

Sometimes if you need a particular app or game you just have to run Windows natively, either in a virtual machine hosted by Ubuntu, or by installing Windows in a partition then choosing Windows or Ubuntu at boot time.

As you can see from the information I posted, it is strongly recommended to install the alsa-tools packages, because you then get the “envy24control” panel to configure the Delta 66.

sudo apt-get install alsa-tools


sudo apt-get install alsa-tools-gui

then to launch the envy24 control panel


Or you can install alsa-tools (console based) and alsa-tools-gui from “Ubuntu Software Centre”. I would install both because you never know if you may need the console tools, given you seem to have audio issues.

You can always use the Ubuntu forums if you need help using Ubuntu.


I got the tools and the envy control installed.
Is this supposed to show the Delta 66? I restarted and still nothing shows up.

Where exactly does Delta 66 not show up? You can see in the title bar of Envy24 that it is reading
the Delta 66 device.

If you are not sure what you are need to do, using the internet to find out is a good plan. For example you may want to read

Note that I do not have your Delta 66 device nor as far as I know does anyone else here.


Gale, I owe you an apolotgy. I never looked at the top of that image. We can close this now. The delta 66 is woeking. I can’t thank you enough.