Sound delay while recording

The sound I hear while recording is 13 seconds delayed. I’ve never encountered this before: any idea how to troubleshoot it?


Can we assume you’re listening to the computer? Headphones? What are you recording?

I have no idea what’s causing this, but I know how to troubleshoot it. Fill in that information.


Thanks! I’m recording old vinyl records on a Windows 10 computer, listening via external computer speakers. It’s the same configuration (and the same computer) I always use. But this has never happened before.

FWIW, playback of a recording works fine without delay. It’s only listening as I’m actively recording that’s delayed.

Hope that helps,

It’s only listening as I’m actively recording that’s delayed.

Right. That’s Edit > Preferences > Recording > [X] Playthrough.

external computer speakers.

Wired? Wireless?

Just so we’re clear, the time from needle drop to the time music actually comes from the speakers is around 13 seconds?

Pay strict attention. When you do a needle drop, do the Audacity bouncing sound meters and blue wave displays arrive almost immediately followed 13 seconds later by the speakers? Or is it 13 seconds from the needle drop to any reaction at all?

You hit an impossible problem. There’s no place to hide 13 seconds of sound by accident. You may have a compromised computer (breakin) or a damaged connection to a cloud drive.

It’s also possible this is a bogus post and you’re laughing at us right now.


Thanks for asking for that clarification, Kozikowski. I turn on Record then drop the needle. The video responds immediately, showing the recording happening. But the audible sound through the speakers (wired) doesn’t start for about 13 seconds. And it doesn’t pick up in the middle of the recording; it starts with the needle drop, so it doesn’t correspond at all to what’s showing on the screen.

When the track is done and I see the evidence of that on the screen, I can click the Stop button and the audio stops immediately, even though I haven’t heard the end of the track. But I can then go back and play what was recorded and the end of the track that I didn’t hear while recording is audible just fine. And if I play what’s just been recorded, it plays through the speakers without any delay.

I realize how crazy this sounds, and I assure you it’s not a bogus post. I’ve recorded a short demo which I’m uploading now. I apologize that the video is a bit choppy and looks very pixilated, but I think it’ll illustrate the problem.

I realize how crazy this sounds

I just wanted to be clear that we do occasionally get sucked into a rabbit hole of a posting that not only seems impossible, it actually is.

One more post. Using either PrtScrn or the Windows Snipping Tool, capture a clear still picture of Audacity during the capture. The motion compression artifacts in the MP4 make that really hard to read.

By the way, there’s a trick to that. Put your camera/phone on a mount or tripod. Set it up so it looks at the screen without you holding it. Doesn’t have to be a tripod. Tape it to an oatmeal box.

Start record and the performance. Pick the whole thing up and move it to (for example) the actual needle drop, and then return it to the stable position looking at the screen and let go.

Your nervous hand motions are causing a majority of the pixel distortion.

I’m hoping a reading of the Audacity settings can give a clue. 13 seconds is a long time to delay sound.

Do you use external drives or cloud storage? Do you record internet or Youtube music or shows?

Is this a laptop? Does it do this if you record the built-in microphone?


Sorry about the video — if you need a better version, let me know. In the meantime, here’s the screenshot you requested.
Audacity screenshot.jpg


Nothing obvious. How about these?

Do you use external drives or cloud storage? Do you record internet or Youtube music or shows?

Is this a laptop? Does it do this if you record the built-in microphone?

There is one oddity. You’re only recording one sound channel. See the recording meter only has one throbbing green bar. If this is a stereo music system, I would expect two, left and right. Is that intentional?

What happens if you disconnect the network? If it’s WiFi, shut it down or if it’s wired ethernet (cable), disconnect it. Same problem?, Did the system complain loudly?


You normally can’t listen to the computer while you’re overdubbing (for example) because your return voice will be late or have an echo. You can’t sing to that. That’s the transmission, processing, and other delays in the computer.

I have been known to listen to that when I’m playing recording engineer for someone else since that is a terrific certification that I am indeed getting a recording. I can wear large headphones and just not pay any attention to the delay.

It’s almost certain that’s not what you have. 13 seconds is enough time to get your keys, go out to the car, get your hat, and come back.

That’s why I wanted to know if this is a laptop and it does that trick with the built-in microphone.

13 seconds of sound has to go somewhere. Storing sound with reasonable fidelity is not that easy.


Thanks for your thoughts. This is an old mono 45; I do normally record in stereo. Here are the answers to your questions:

This is a laptop in a docking station, using external keyboard, monitor and mouse through a KVM switch.

I never (at least yet) recorded from a microphone or attempted overdubbing.

I’m not using cloud storage or anything of the sort and all I use Audacity for is digitizing old records and tapes.

I disabled Wifi and unplugged the Ethernet cable. I confirmed I’m not connected to the Internet.

Nevertheless the same symptom is still replicable.

I’ve tried rebooting my computer— the universal technical fix— but that didn’t help.

Do you think I need to appeal to the developers? I don’t know if I even CAN do that.

Is there any value to be found in the log?
Audacity Log.jpg

Do you think I need to appeal to the developers?

You and the fifty other people having exactly the same problem can appeal to the developers. You are a Unicorn. A one-off problem. This isn’t a 'Bug" for the same reason. There have been serious problems revealed by a single error forum posting, but they’re super-duper rare.

I’ve never encountered this before

Before what? All this was working perfectly before you changed what? Did you upgrade to Audacity 2.1.3 from an earlier Audacity version 2? Did you update Windows?

I see three branches:

– Change the recording device to the Built-In Microphone and see if it still does it. Turn down your speakers to avoid feedback or plug in headphones. Of course with a 13 second delay, howling feedback is almost impossible

– Install Audacity 2.4.2 from here.

Scroll down. Note if you have some Audacity 3 Projects, they will not open in Audacity 2.

– Wait for the impending Next Generation of Audacity which promises to solve some very serious file management problems in the current release.


What settings do you have in “Audacity menu > Preferences > Recording”?

I’m just doing a line recording from a turntable; no mic, so no need to turn off speakers, right?

What changed since the last time it was fine? It’s been awhile, so as soon as I first opened it last week, it offered to download an update to 3.1.2, which I took. Reverting back to the version you recommend sounds like a great idea. I’ll do that now.

Thanks for the suggestion to revert to 2.4.2! That fixed it right up! It must either be something unique in 3.1.2 or something cot corrupted during the upgrade.

Thanks for sticking with me through this!