Sound activated recording problems

I’m currently under a constant situation where sound activated recording misses the first second of audio, and keeps producing silent audio afterwords without pausing recording.
There is no noise keeping SAR going.
I have already tried reinstalling.
Audacity 2.4.2, Windows 2004 19041.450.

What are your “Latency” settings (both) in “Edit menu > Preferences > Devices”?

Buffer Length: 100
Latency Compensation: -130

The sound activated recording problems have gotten worse, it sometimes can take up to 10 seconds before it starts recording, and it looses all 10 seconds. Oddly enough, the monitor is instantaneous.

That’s weird. It sounds like Audacity is fighting to gain access to the recording device. Do you have other audio software running? What are you recording from? Have you tried lowering the activation level?

The activation level is -55db. The monitor is able to capture fine, so I don’t understand how it would be fighting if the db monitor (the bar at the top) would be tracking it fine.
I am using Windows WASAPI using a VB-Cable , however other audio devices have the same issue.
What it seems to be is a strange offset. The length of the capture is correct, but the time when it starts is wrong. For example if I were to speak for 5 seconds, it would start capturing 10 seconds later for exactly the 5 seconds I spoke, and produce empty sound because I’m not talking anymore, I was, 10 seconds ago.

Do you absolutely need VB-Cable? We’ve had quite a few reports of strange problems like this when VB-Cable is installed (not necessarily being used, just running in the background appears to be enough to cause problems for some).

Yes, I’ve been capturing system audio. I also use Virtual Audio Cable, I have 6 of them active, all doing individual processes, using multiple Discord bots and instances.
This problem only started occurring recently, when Windows 10 2004 came out.

I have 6 of them active…multiple Discord bots and instances

If you’re happy with the way Virtual Audio Cable is working, then Audacity may not be a good match for you.

As Steve above, Audacity has had documented trouble working with VAC and you have multiple channels and directions working at once. Audacity is designed for and works well on simple systems with one record and one playback channel.