Sound Activated Recording not working

I am using Audacity 3.1.3 on Windows 11: I finally upgraded from Windows 7!

I like to record several songs onto a single Audacity track with a gap between, where I can insert my DJ links later.

Audacity only records now when there is something playing. As soon as the song ends, or if there is a gap during the song, it stops recording. Following advice in other discussions, I’ve checked that Sound Activated Recording is Off. I even set the Sound Activation Level to the lowest possible, -60, but that made no difference.

I read somewhere that if there is no actual sound, there is nothing for Audacity to record. But my older version managed to do so OK.

Interestingly, I can force Audacity to record songs, with silent gaps between, if I simultaneously play a track of Silence, generated earlier by Audacity, on loop. It’s as if Audacity is detecting that some software is playing something, rather than there being actual bits of sound to record. Does that make sense?

What else can I do to make sure that Sound Activated Recording really is Off, and get Audacity to record nothing at all, if that’s what I want?

I read somewhere that if there is no actual sound, there is nothing for Audacity to record.

You’re recording streaming audio with WASAPI (loopback), right? It can a silent stream but it won’t record when there is no audio stream.

If you’re not recording streaming audio, don’t use (loopback) and this won’t happen… If you’re using a soundcard, it’s always sending data even if it’s silent data (a bunch of zeros).

Yes, using WASAPI. If I play from two sources simultaneously, one of which is Silence, Audacity records continuously. So the end result is one track comprised of several songs with long gaps between. If I pause or stop the Silent ctsource, then Audacity will stop recording when the actual Noise source stops. I thought Sound Activated Recording being Off would mean that Audacity records everything between pressing Record and pressing Stop: the older version certainly worked that way, in fact, I was then unaware of the Sound Activated Recording option.