Songs recorded through audacity are quiet compared to others

Hey folks

Recently I started a little project to create a custom playlist. I’m taking a series of long-ass movements (20 minute pieces on average) which are all one track when purchased on iTunes, and splitting them down into separate 1 - 2 minute tracks, while also removing some bits and applying minor effects like fade in/out. This allows me to “shuffle” the songs and listen to them in a random order, while still flowing nicely.

In any case, because of the encryption on iTunes purchased songs the best I could manage was playing the song through iTunes and recording using the “WASAP” recording thing.

Worked fine, and didn’t notice any degrading quality. It sounds great when I’m only playing those songs in a random order.

My problem occurs when I want to play the songs back as part of my playlist, which includes other songs purchased on iTunes and not modified.

The files I’ve recorded using WASAP aren’t as loud as the others, meaning I have to keep constantly adjusting the volume to my liking - defeating the purpose of a playlist I can just zone out and listen to.

I’ve tried amplifying the audio, with limited success - but the main issue is that the audio when read in audacity seems to keep hitting the +1.0 ‘cap’, which is still not loud enough.

If I amplify any more than this (Allowing clipping) then the audio starts to crackle at the loud bits, despite not being excessively loud when compared to other audio files.

How can I make the songs louder without that crackle occurring?

It seems like the ‘peak’ value is too low somehow.

Many thanks,

The WASAPI recording volume is set internally. You could try Tutorial - Recording Computer Playback on Windows to see if you can enable stereo mix or similar for your sound card.

You could burn the songs to CD then rip the CD, which would get the audio off the CD exactly as it is. However if it’s not loud enough even when amplified to 0.0 dB it sounds to me like you need to use Effect > Compressor… on it.


Hi Gale

Thanks for your response.
I have viewed the thread you mentioned, but found myself unable to record directly from Windows using anything other than WASAPI. There were a few other options available but they all seemed to record from the inbuilt microphone in my laptop.

For example, when selecting MME in the host box, the two options I get are “Speakers (Realteck High Definition…)” and “Microsoft sound mapper”. As far as I could see neither were recording the audio being played.

I am little confused about why I can’t seem to amplify the audio recorded through WASAPI more than a relatively small amount?

My headphones etc. can definitely play louder without crackling - as can be seen if I whack the volume right up - so why is clipping occurring for this audio file which still seems slightly too quiet when apparently at ‘maximum amplitude’.
It seems to me that I should be able to amplify the waveforms as much as I like - and clipping would occur only as a physical constraint on the speakers.

Or perhaps I have not understood properly what this clipping is and why it’s happening?

Finally, it seems to me that the compressor won’t change the ‘maximum volume’ of the audio file - it would just allow the quieter parts to be amplified closer to the louder ones by reducing the difference between each.

I guess my main concern is why things amplified to their ‘maximum’ in audacity aren’t loud enough?!

Thanks again.

I suggest you look at this link Missing features - Audacity Support . That explains how to show and enable disabled devices such as stereo mix or what U hear for recording computer playback. There is no guarantee your sound card has one of those inputs, but you should look for and enable such an input in Windows before assuming you don’t have it.

Also as I said, you could burn the songs to CD and rip the CD. Then the volume of the songs would be unaltered.

Also you could subscribe to iTunes Match . Then you will get new copies of your DRM’ed songs without DRM. If the songs are remastered to be louder - very likely given the Loudness war, then your problem will be solved.

If the audio is not loud enough even after amplifying it to 0 dB, you will have to use Effect > Compressor on it. Compressor reduces the dynamic range (difference between loud and soft) and so makes the whole song sound “louder”. Oversimplifying, Compressor can make the loud quieter (downwards compression) or the soft louder (upwards compression). Both methods make the audio sound louder if you amplify after downwards compression, which Audacity does by default (it’s called “Make-up gain”).

We can’t see your song, but if there a few peaks almost at 0 dB those are the reason you can’t amplify the whole very far. Bringing down the peaks using rms compression (“Compress based on peaks” unchecked) then lets the “Make-up gain” make a worthwhile increase in volume when it brings the track up to 0 dB.

No. If the original audio is 16-bit or 24-bit which it definitely will be, then you cannot Amplify beyond 0 dB without introducing distortion. 16-bit and 24-bit audio simply cannot represent audio above 0 dB.

That is exactly what makes the audio “sound” louder. It increases the amount of light blue (average or “rms” volume) in the waveform. The rms component is a much stronger indication of loudness than peaks. Try it.

Do the songs sound loud enough in iTunes? Do you have the Audacity output slider turned up?