"Some projects were not saved properly..."[SOLVED]

Hi all,

I’m having a peculiar problem. I’m the IT person for a small satellite campus and one of the language professors here gets the same error message every time she opens Audacity . The Autocrash Recovery window opens with the message, “Some projects were not saved properly the last time Audacity was run. Fortunately the following projects can be recovered”. Then there is a list of “Recoverable Projects” and the options to “Quit Audacity”, “Do not Recover” or “Recover Projects”.

The problem is, the files listed as recoverable don’t exist. They were deleted from her machine ages ago. And, oddly, if she clicks on “Do Not Recover” Audacity simply shuts down. If instead she clicks on “Recover Projects” a new window pops up stating “error opening Project … Couldn’t find the data folder : FILENAME.”

The professor can then click OK on this screen and use Audacity just fine, but it is frustrating that every time she opens audacity she runs into this problem and it isn’t always the same file that Audacity notes as improperly saved. I am including screen caps of the two step process we need to click through to finally allow her to use Audacity and I’m hoping someone might have some advice on how to put an end to this constant interruption (and yes I have reinstalled Audacity - twice).

She’s using a Macbook with OSX 10.8.2 and we’re suing the most recent update of Audacity: 2.0.3
Capture d’écran 2013-03-04 à 12.44.52.jpg
Capture d’écran 2013-03-04 à 12.45.04.jpg

Have you opened Finder, done Go > Go to Folder then typed:

  ~/Library/Application Support/audacity/AutoSave

and verified that the AutoSave folder is empty? Because if it is empty Audacity should have no motivation to be opening unsaved changes to projects.

In an attempt to stop this happening, make sure Audacity is quit (Audacity > Quit Audacity) then navigate up to ~/Library/Application Support/audacity and move the AutoSave folder to Trash, then delete the AutoSave folder from Trash.


This worked perfectly. for some reason, I couldn’t find the folder with the corrupt file in it. Spotlight was returning no matches for the filename. But when I went to the directory you specified, boom, there it was. Deleted the file and all is good now. Many thanks.

Glad it was solved.

Spotlight won’t search the user’s Library by default. To search there you have to press the “+” button in the search result, choose “System files” for “Kind” then “are included” to the right of that.