Some audacity files not saving

I’ve lost hours of editing work over the past week because of files not saving in Audacity, even when they look like they have saved, they are blank. I get this message: Audacity failed to read file. I’ve been using Audacity without problems since April and only had problems with progress not being saved now. I’ve deleted files to make sure there is room. I’ve saved new files only to an external hard drive. That doesn’t help. It saves sometimes and not others. Yesterday I tried saving every 10 to 15 minutes. It worked great the first three times. The fourth time it looked like it worked but it was blank when I checked and the fifth time gave me the error I mentioned above. When I saved a new audio file in Audacity it did work. It does not come back when I restart Audacity. I’ve tried multiple things including uninstalling Audacity and reinstalling but nothing. Sometimes the file even looks like it’s there but it’s not. This is very frustrating to me and I’ve overdue on an audiobook deadline but I can’t make it because I keep getting this problem so I’m re-doing editing. I’m nervous now every time I work on it wondering if I will lose it again. Please help!!
I have windows 10 on a Dell laptop. I get this message
“timestamp”: 1634216496,
“event_id”: “822edb553d66a54b8127e42471863b53”,
“platform”: “native”,
“release”: “audacity@3.0.5”,
“contexts”: {
“os”: {
“type”: “os”,
“name”: “Windows”,
“version”: “10.0.19041”
“exception”: {
“values”: [
“type”: “File_Error”,
“value”: “Audacity failed to read from a file in .”,
“mechanism”: {
“type”: “runtime_error”,
“handled”: false,
“data”: {
“sqlite3.rc”: “11”,
“sqlite3.context”: “SqliteSampleBlock::Load::step”

Where are the drives? Are you using on-line virtual drives such as Google Drive? Are those drives connected even you’re not using them?

Windows Audacity has a setting to do a clean start when you re-install. Did you check that?

When Audacity fails like that, do you clean start Windows?

Shift+Shutdown > Wait > Start.

How long is the show? How many tracks?

Are you using a great many downloaded tracks?


Audacity 3.0.5 has Save Backup.

Regular Save keeps repeatedly updating one single show file. If anything happens to that one file, that’s the show in the trash bin. Audacity also has Save Backup which makes a completely divorced show file (use a different name). If the show gets damaged, you can “step back” to an earlier version and keep going.

This works less well if you’re using cloud drives or are incorporating an aggressively evil music download. Those can damage anything they touch.

Restarting Windows is handy if you have conflicting apps by accident.

Audacity and Zoom hate each other.


Error code 11 translates to a corrupt sqlite3 database. See here for sqlite3 error codes: Result and Error Codes

In individual cases, I have had some luck in dealing with this particular error. If you care to zip up your .aup3 file, upload it to a file sharing service, and post (or PM me) a link, I’ll take a look at it. No guarantees.

Error code 11 translates to a corrupt sqlite3 database.

Is this a show error, file error, or install error? Is Audacity on this machine always going to have this instability? Would Save Backup have helped?

Is this a good time to reinstall Audacity 3.0.5 with the Clean Start option checked?

Is there a “personality” to this disorder? It typically only happens on long shows?