[SOLVED] Permission issues when opening up smb/cifs mounted files

before you start yelling at me about how it’s permission issue with the mount, or the FS, or the user,

the user account that audacity is running under can :
cd the whole tree to the files
run ffprobe/ffmpeg on the files (mp3s)
play the files in vlc and mpv, both from the shell and from nautilus
all of the above works fine.
ps -ef says audacity is running under the same account as the above.

the audaciy log just says error 13 (Permission denied).

Ubuntu 18.04.2 LTS
Audacity 2.3.2 installed via snap.

I was previous running audacity 2.2.1 from the ubuntu repro and it did not have this issue.

Here is the mount from fstab:
//nas1/media /media/user_me/media cifs noperm,noauto,credentials=/home/user_me/.smbcredentials 0 0

Any ideas, or better logging to turn on? Maybe a strace?

A full description of what you are trying to do would be useful.

Just trying to open a mp3 file on a network mounted drive. Either by File → Open, or by drag-n-drop the file via nautilus. Both from a freshly launched audacity.

Also of note : Audacity’s file picker can’t navigate the /media directory, even though it’s permissions are set to read by everyone. Permission denied

ls -ld /media
drwxr-xr-x 3 root root 4096 Jul 10  2018 /media

I’ve just been entering the fill path to the file in Audacity’s file picker, but the result is the same.

again. no other apps seems to have a problem playing files off this mount, and a shell under the same user seems to have proper access.

I’ve just checked, and Audacity doesn’t support SMB protocol. What I generally do is to just copy the files to a local disk.
Also, note that it is a bad idea to work on “projects” on a network drive because Audacity expects immediate access to its data. There is no network buffering built into Audacity.

I don’t understand. It’s a mounted file system. There is no need to support anything except opening a file. the OS takes care of the details of SMB, or NFS, or ext3 or FAT or whatever the file-system is.

The first thing Audacity does with mp3 files is de-compress it. I assume it uses /tmp or some other local cache for that. so there shouldn’t be any perf issues with using network FS becides the inital de-compress. Either way,… Audacity doesn’t need any SMB count. VLC doesn’t have any, and it works fine opening files on a network FS. Also, version 2.2x worked fine. So I still think there is an issue here.


Turns out this is a problem with snap installed software. By default it can’t access any file outside of your home directory or any removable media. The 2.2.x version I had installed was via apt-get, so that’s why it worked.

using the --devmode flag on the snap install fixes it (note: the --classic flag does not).

Seems crazy that snap would limit access to any files outside of your home-dir by default. At least it seems crazy for any type of pix/video/audio editor where removable media is highly likely. Oh well… not my hill to die on.