[SOLVED] Looking for a plugin like Sliding Time Scale / Pitch Shift

Hi there.
I’m running Audacity v2.4.2 on Linux Mint 20. Linux version 5.10.0-4.3-liquorix.
I just switched to Linux because Windows is a nightmare. But back when I used Audacity on Windows, there was this neat plugin called “Sliding Time Scale / Pitch Shift”. I tried to find a similar VST plugin on Gthub, but with no luck.
Do any of you know if there’s a similar plugin for Audacity on Linux?
My use case is to pitch from normal sound down to screwed.
Thanks in advance.

EDIT!
Solved thanks to @Geolgar
Compile Audacity from source after patching the source code as explained here:
https://forum.audacityteam.org/t/bug-crash-after-using-high-qualitty-stretching-solved/58690/1
And also thank you @Steve for all your help.

In Audacity 2.4.2, “Sliding Time Scale / Pitch Shift” was renamed as “Sliding Stretch”.

Thanks Steve, but I can’t find that one either.

I’m not sure if this plugin is available for Linux.
Is there anywhere I can find Audacity plugins for Linux?
I just need this (or similar) plugin.

The “Sliding Stretch” effect is not a plug-in. It is a built-in effect in Audacity 2.4.2.
(see: https://manual.audacityteam.org/man/sliding_stretch.html)

If you still can’t find it, try doing a reset (“Tools menu > Reset Configuration”)

Right. So it should be under Effects which it isn’t.
Are you sure that this effect is available for Linux?
And if not (or even if), where can I download Audacity plugins and effects for Linux?

Absolutely. I’m using Xubuntu 18.04, and this is a screenshot from Audacity 2.4.2:

stretch.png

What effects do you have listed in the Effect menu?

Aplify, Auto dock, Bass and trable, Change pitch, Change speed, Change tempo, Click removal, Compressor, Distortion, Echo, Fade in, Fade out, Filter curve, Graphic EQ, Invert, Loudness normalization, Noise reduction, Normalize, Paulstretch, Phaser, Repair, Repeat, Reverb, Reverse, Truncate silence, Wahwah

Nothing below Wah Wah?

Are you using a Flatpak or Snap package?

Nothing below but the 2 Plugins listing. Plug-in 1-15 and 16-18.
And no. I’m using the standard repository version.
However. I did just now install the Flatpak version just to check, and Sliding Stretch is indeed included there.
However, it doesn’t work. When I press Preview in that Sliding Stretch window, a debug dialog appears.
It said it generated a report zip file in my /temp folder. But that file did not exist.
Anyway. That’s flatpak. I’d very much like to know how I can get this plugin working in the normal version.
EDIT: Now the effect is not even showing in the Flatpak version.
This is very strange.

Good, so you do have the other 18 plug-in effects.


I don’t recommend either the Flatpak or Snap versions of Audacity as we have multiple reports of problems with them.

I’d suggest that you uninstall all versions of Audacity, and then delete the hidden folder:

~/.audacity-data/

“~/” means your home folder.

Then install Audacity from the command line so as to ensure the correct version:

  1. Open a terminal window
  2. Enter the command:
sudo apt install audacity
  1. Enter your password when prompted.

Right. Like I said. That’s the version I initially installed.
So now I’ve removed both the flatpak and regular version, removed its data files (~/.audacity-data/ and ~/.var/org.audacityteam.Audacity) and installed Audacity again from apt.
Still nothing.

What is the exact version number of Audacity according to your package manager?
Is it “2.4.2~dfsg0-3”?

Yes.

Unfortunately it appears that the packagers have disabled SBSMS, which is the time stretch library used by Sliding Stretch.
This also means that the high quality settings in “Change Pitch” and “Change Tempo” are also unavailable.

I don’t know why they have done that.

Probably the best option if you want this feature, is to build Audacity from the source code.
I posted instructions for Ubuntu 20.04 here: https://forum.audacityteam.org/t/building-audacity-2-4-2-on-ubuntu-20-04/57719/1
I think those instructions should also work on the latest Mint, but I have not tested.

Hi. On my 2.4.2 build from source using the Steve guide, doesn’t show the Sliding Stretch either.
But you can enable it by going to:
Effects/Add-remove plugins and search for it. Click enable and that’s it.
It works nice for me. But I also used the patch that Steve send me to solve the High Quality change pitch effect. Maybe you would need that too.

Thanks. I compiled it from source, but I got the same error/debug dialog as from the flatpak installation.
So I guess the only version that’ll work is 2.3.3 (or whatever the previous version was) ?
Guess I’ll build that one from source instead and see how that goes.

Update! 2.3.3 Works. I installed the 2 packages “audacity-data_2.3.3-1build1_all.deb” and “audacity.3.3-1build1_all.deb” from packages.ubuntu.com > focal.
So whatever happened in version 2.4.2 is most likely a bug. Would be nice if someone smarter than me could figure out what that bug is and roll out an update to both Flatpak, the Ubuntu repo as well as the Handbook1 Audacity PPA.

As I wrote earlier, SBSMS has been disabled by the packager.
It says so in “Help menu > About Audacity > Build Information”.