[Solved] Error opening audacity

Hi all,

Distribution: Manjaro Linux
Audacity installation package: Audacity-wxgtk2 | AUR

Today when trying to open Audacity normally from the application menu, I noticed that it wouldn’t launch.

I opened the terminal and tried through it and it showed me this information below:

audacity                                                                                       ✔ 
audacity: error while loading shared libraries: libSoundTouch.so.1: cannot open shared object file: No such file or directory

I did research on the WWW about libSoundTouch.so.1 and didn’t find anything that would make me solve this

Thanks in advance for any tips

Best regards from Brasil!

T+ = See you later

I’m not sure who packages the .aur repository version, but the only updated version is the AppImage that you can download from the link at the top of this page. Are you able to try that?

Note that appimage files aren’t installation packages, they are directly executable - you just have to set the executable bit.

Hi @SecretCode and thank’s,

:smiley: :smiley:
I always avoid using appimage, etc, etc, especially if it is (PPA, Snap or flatpak) but I will try Appimage

The AUR package is the 3.1.3-1 And the audacity-wxgtk2 packager is from the AudacityTeam forum is the >> “osch” <<

Thank you again

T+ = See you later

3.1.3 is the latest version, so someone in the Arch / Manjaro community is keeping busy!

Simple test: if you get the same problem with the appimage, then it’s an Audacity problem … if you don’t then, then it’s a packaging error :wink:

The packager is >> “osch” << from the audacityteam community

pamac info audacity-wxgtk2                                                                     ✔ 
Nome                            : audacity-wxgtk2
Versão                          : 3.1.3-1
Descrição                       : Record and edit audio files
URL                             : https://audacityteam.org
Licenças                        : GPL2 CCPL
Repositório                     : AUR
Tamanho instalado               : 54,6 MB
Grupos                          : pro-audio
Depende de                      : libmad libid3tag gtk2 glib2 soundtouch ffmpeg vamp-plugin-sdk portsmf
                                  portmidi twolame suil lilv lv2 serd sord sratom python flac libvorbis
                                  libogg vamp-plugin-sdk portaudio libsoxr libsndfile lame expat alsa-lib
                                  jack util-linux util-linux-libs curl zlib
Dependências opcionais          : --
Criar dependências              : cmake autoconf automake libtool git conan
Verificar dependências          : --
Exigido por                     : --
Opcional para                   : --
Fornece                         : audacity
Substitui                       : --
Conflita com                    : audacity
Empacotador                     : Unknown Packager
Mantenedor                      : osch
Primeira submissão              : sex 22 jun 2018 04:58:26
Última modificação              : qua 29 dez 2021 10:27:31
Votos                           : 10
Data de construção              : sáb 29 jan 2022 17:45:57
Data de instalação              : sáb 29 jan 2022 18:22:01
Motivo da instalação            : Explicitamente instalado
Validated By                    : None
Cópia de segurança dos arquivos : --

T+

Well the solution came with your suggestion @SecretCode, thanks a lot:

1 - I downloaded the AppImage and ran it on my machine ./audacity-linux-3.1.3-x86_64.AppImage, ok
2 - I closed the AppImage and went back to the menu and opened the normal Audacity was, I went back to the terminal and commanded “audacity” and it opened again

audacity                                                                                       ✔ 

(process:29164): Gdk-CRITICAL **: 20:16:29.361: IA__gdk_screen_get_root_window: assertion 'GDK_IS_SCREEN (screen)' failed

(process:29164): Gdk-CRITICAL **: 20:16:29.363: _gdk_pixmap_new: assertion '(drawable != NULL) || (depth != -1)' failed
/home/cretokde/.conan/data/wxwidgets/3.1.3.1-audacity/_/_/build/130288072304580eba516027ffe9f26f82ad6965/source_subfolder/src/gtk/bitmap.cpp(827): assert ""IsOk()"" failed in ConvertToImage(): invalid bitmap
/home/cretokde/.conan/data/wxwidgets/3.1.3.1-audacity/_/_/build/130288072304580eba516027ffe9f26f82ad6965/source_subfolder/src/common/image.cpp(2172): assert ""IsOk()"" failed in SetMaskColour(): invalid image
/home/cretokde/.conan/data/wxwidgets/3.1.3.1-audacity/_/_/build/130288072304580eba516027ffe9f26f82ad6965/source_subfolder/src/common/image.cpp(2223): assert ""IsOk()"" failed in SetMask(): invalid image
/home/cretokde/.conan/data/wxwidgets/3.1.3.1-audacity/_/_/build/130288072304580eba516027ffe9f26f82ad6965/source_subfolder/src/common/image.cpp(1853): assert ""IsOk()"" failed in GetWidth(): invalid image
/home/cretokde/.conan/data/wxwidgets/3.1.3.1-audacity/_/_/build/130288072304580eba516027ffe9f26f82ad6965/source_subfolder/src/common/image.cpp(1860): assert ""IsOk()"" failed in GetHeight(): invalid image
/home/cretokde/.conan/data/wxwidgets/3.1.3.1-audacity/_/_/build/130288072304580eba516027ffe9f26f82ad6965/source_subfolder/src/common/image.cpp(2112): assert ""IsOk()"" failed in GetAlpha(): invalid image
/home/cretokde/.conan/data/wxwidgets/3.1.3.1-audacity/_/_/build/130288072304580eba516027ffe9f26f82ad6965/source_subfolder/src/common/image.cpp(2232): assert ""IsOk()"" failed in HasMask(): invalid image
/home/cretokde/.conan/data/wxwidgets/3.1.3.1-audacity/_/_/build/130288072304580eba516027ffe9f26f82ad6965/source_subfolder/src/common/image.cpp(1986): assert ""IsOk()"" failed in GetData(): invalid image

(process:29164): GdkPixbuf-CRITICAL **: 20:16:29.364: gdk_pixbuf_new_from_data: assertion 'data != NULL' failed

(process:29164): Gdk-CRITICAL **: 20:16:29.364: IA__gdk_screen_get_root_window: assertion 'GDK_IS_SCREEN (screen)' failed

(process:29164): Gdk-CRITICAL **: 20:16:29.364: IA__gdk_drawable_get_display: assertion 'GDK_IS_DRAWABLE (drawable)' failed

(process:29164): Gdk-CRITICAL **: 20:16:29.364: IA__gdk_cursor_new_from_pixbuf: assertion 'GDK_IS_DISPLAY (display)' failed

(process:29164): GLib-GObject-CRITICAL **: 20:16:29.364: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

Thanks for your patience @SecretCode, “Solved

T+ = See you later

Come on, now I come to inform you of the solution that I have always found thanks to the “free software community”.
Uninstall ‘AUR conan’

And install through “pip”

/usr/bin/python3.10 -m pip install -U conan

Source: uiliaries comment

And thanks to @osch, because if it wasn’t for him, as usual, I wouldn’t get the solution, thank’s for all!

T+ = See you later

Conan is only required for building Audacity, it is not required for running Audacity.

As I use Python a lot, I prefer to use virtual environments, so the way I install conan is:

  1. Navigate to the Audacity source folder
pipenv install conan
pipenv shell
  1. Configure and make Audacity

More about pipenv: Pipenv: Python Dev Workflow for Humans — pipenv 2023.11.16.dev0 documentation