[Solved] Digital recording from other apps fails in Win 11

Hello. In Win 11 Audacity fails to open the same WASAPI recording device which I did use in my previous PC with Win 8 (a month ago). The audio chip is Realtek in both cases - the device settings in Audacity looks identical. I used both 3.2.1 and older 2.0.5.

I enabled MME/StereoMix device in Win 11 settings and now recording from other apps do work both in 3.2.1 and 2.0.5, BUT it looks like this is an analog path, not digital. Attached screenshot shows the very begin of the recording (with 2.0.5 that I use now for reasons) and shows how much is the noise floor during all the recording (here I had no other apps). In Win 11 settings, I disabled all effects in StereoMix so that this should be a raw recording.

Note that most Youtube videos gives the StereoMix as the solution to the device problem, but looks like nobody noticed it records bad signal. That is weird. What is going on?

This is now solved! The problem was that WASAPI in Audacity did not go on – Audacity gave an error.

While Windows 11 has its own sound enhancement setting (was off already), the HP computer has additional HP Audio Center with its own HP experience enhancement. In HP Audio Center, I both turned HP experience off and modified channel setting from quad to stereo. The result is that WASAPI in Audacity goes on.

Sadly, the default HP settings made the audio bad and unsuitable for HiFi. See the screenshot in the original post. Also sadly, HP experience boosted some bass.