[SOLVED] ***BUG*** on stderr and recording not working

Audacity gurus,
I’m reaching out asking for help diagnosing why two different versions of audacity will both play output to, but will not record audio from, either my Kingston HyperX Cloud II USB headset or my SteelSeries Fnatic analog headset, on any of the motherboard or Nvidia mic input ports, and why so many ALSA errors appear on stderr, including one that says “*** BUG ***”.

The OS is xubuntu-19.10 : “Linux CUDA1 5.3.0-24-generic #26-Ubuntu SMP Thu Nov 14 01:33:18 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux.”
(The machine is a 16-core desktop with dual Nvidia GTX 780 Ti cards; the output of “lshw” listing two cards is correct).

The ALSA version is : “Advanced Linux Sound Architecture Driver Version k5.3.0-24-generic.”
The two Audacity versions are:
Audacity 2.3.2-2 (ubuntu-eoan-universe) and
Audacity 2.3.3-1 (ppa:ubuntuhandbook1/audacity)

Attached are typescript files showing the errors reported on stderr upon startup of each version of Audacity. I am not actually concerned about the “pixman_region32_init_rect” bug right now… I am concerned with getting recording working. I believe the problem has to do with my alsa installation and I am asking for help diagnosing and fixing it. I have also attached a screenshot of what Audacity displays as the valid microphone input selections. None of the available selections receives any input from either headset microphone.

Is this amount of stderr outputs expected and if not, how should I proceed to diagnose & repair my installation?
p.s. “Skype” doesn’t receive any audio input from the microphone either.
With the HyperX USB heaset plugged in, “pavucontrol” shows the input device as "Monitor of Built-in Audio Digital Stereo (IEC958) and it is not muted, but it shows no digital input available in the input device Configuration list (screenshot attached).
If there’s any more info I should have provided, please let me know… thanks!
typescript-audacity-2.3.2.txt (9.89 KB)
CUDA1.lshw.txt (48.3 KB)

The bug in pixman is probably triggered by GTK3. That bug affects multiple apps, not just Audacity. The problem does not appear to happen if Audacity is built with GTK2. It is probably not fatal for Audacity.

ALSA warning on startup are normal because Audacity is querying the sound system to see what devices are available. When Audacity queries a device for a feature that the device does not support, it is echoed to the terminal as a failure.

It is essential that any device that you wish to use with Audacity is plugged in and working before launching Audacity, otherwise Audacity will not see the device.

Are you able to record from either of your headsets with other software?

thanks for the reply Steve. The only other installed software that I am aware of that accepts microphone input is Skype, and no it does not receive any audio input either. When I boot the machine into Windows instead of Linux, everything works, including Audacity.
Should I reinstall ALSA and if so what is the proper procedure?
Rgds, Dean

Probably not. Attempting to do so is more likely to break things than fix things.

Do you have pavucontrol installed?
If so, with your USB headphones plugged in, go to the “Input devices” tab and see what devices are available.

Steve, the screenshots of pavucontrol’s Input Devices tab and Audacity’s Input Devices pulldown are attached.
Also attached is my alsa-info.sh output, showing that ALSA is recognizing the HyperX device.
In pavucontrol’s Configuration tab I tried setting the HyperX to both digital duplex and analog duplex.
Then I tried each of the six HyperX input devices listed in the Audacity pulldown…still no audio recorded. Any ideas?
Rgds, Dean
alsa-info.txt (77.9 KB)

In the “Configuration” tab of pavucontrol, disable all devices except for the HyperX (the last option in each list is “off”).

For the “HyperX” set the option to “Analog Stereo Duplex”.

Then restart the computer.

Open pavucontrol again (Audacity NOT running).
Go to the “Input devices” tab. The only option should be the HyperX Analog Input.
Ensure that the volume is turned up, and see if the meter responds to your voice.

thank you Steve, I followed your steps and the level meter moved in response to my voice input. yay! However even with only one device configured in the Configuration tab I see two devices in the Input Devices tab: “HyperX Virtual Surround Sound Analog Stereo” on port “Headset Microphone” and “Monitor of HyperX Virtual Surround Sound Analog Stereo”.

If I then launch Audacity there are 54 microphone input devices listed (!) but there is no " HyperX Virtual Surround Sound Analog Stereo" device.
However if I select the “default:line 0” device it does record my voice :slight_smile: This is progress!! But should these 54 devices listed and no “HyperX”? Is this expected?
Rgds, Dean

If pavucontrol is open, then HyperX will not be available as a “hw” device, because PulseAudio has exclusive access to it.

That’s the one that you need.

Was that the “Headset Microphone” ?

… yes the Headset Microphone device is the one whose volume meter moved, and yes I see that if I close pavucontrol then I get HyperX in the Audacity microphone and speaker device pulldown menus. That increases the number of menu items from 54 to 55 :slight_smile: It does work if I select that device, but should the other 54 be there? They sort of look like they are device parameter names, not device names … Do I perhpas have a syntax error that’s causing a config file to be incorrectly parsed?
Rgds, Dean

Super :slight_smile:
You can probably also use “default” and “Pulse” devices. Both of those should use the default PulseAudio device, which we have set as the headset.

Probably yes. The HyperX headset is a complicated multi-channel device. With Windows drivers, that is probably displayed as a much simplified choice of options. With Linux, you see the technical detail that the device reports to the sound system. It’s not pretty, but once you work out which the “correct” device is, then it’s functional.

thanks so much for your help!

Before I close this thread, I’ll just add, by way of explanation:

I read in the HyperX user manual that the HyperX MUST be set as the default device on Windows and Mac. The HyperX does not officially support Linux, but it appears that it does work, but as for Windows / Mac, it appears that it must be the default device.
I then searched Google for related web pages, and found a forum where someone wrote that they had to disable their on-board sound card to get the HyperX to work. My conclusion is that the HyperX does not play well with others, so you have to ensure that it is not competing with other audio devices.