Slow performance with many tracks

I’m working on a podcast in Audacity 2.0.5 OSX.

It starts out working pretty well, but as my project grows performance starts getting poor. I don’t know if this is because of how I’m working, running low on memory, or what.

I have 8GB of memory. I don’t think it’s a memory issue because my Memory Pressure is green and remains so even during operations that are slow in Audacity.

I have a total of about 1 hour of audio, it’s 44.1 Mono at 16 bit. However, it is split into 24 different tracks and I wonder if this is the reason why things are slow?

The way I work is that I record each segment of my podcast into a separate .wav file and import these into Audacity. I also have separate (very small) .wav files for my transitions between segments. I arrange these in order in Audacity like this:

Intro
Segment 1
transition
Segment 2
transition
…etc…
outro

I use the “Solo” button on tracks to listen to each one individually while I’m editing. Then at the end I use “Tracks->Align End to End” to link all my audio together into the complete episode. Up until that point I can still easily rearrange the order of the tracks. I never play multiple tracks which overlap, because obviously that would result in the audio being jumbled up so Audacity shouldn’t have to do any in-memory mixing, but perhaps it does so anyway since it does not know my intent? I’m wondering if that is the cause of the slowdown…

So what happens is that when I need to snip out or insert a section of audio, it can stall and take a while, even for very small changes.

Previously when I used to record the whole episode as one monolithic .wav I don’t recall having this issue. However, that was also in an early version of Audacity so multiple things have changed since then.

I was reading last night and just learned about the Time Shift tool. I can see that this is an alternate way that you could line up multiple tracks but it seems less “clean” and organized to me and harder to change your mind about the ordering.

Anyway, looking forward to your advice!

  • When you close other applications, do you really close them or leave them running in the background. How many indicators in the application dock are glowing? Actually close things when you don’t need them.

Restart the machine and don’t launch anything except Audacity. If Skype or a browser launches itself, close them.

  • Does your desktop look like an explosion in an icon factory, or are there three or four icons and that’s all? Having to manage a very busy screen can take a performance hit.

  • Have you ever done a periodic? Do you leave your machine alive and awake through 4AM? Most people don’t.

Go > Utilities > Terminal.

Last login: Fri Sep 26 18:12:08 on console
stella:~ koz$ sudo periodic daily weekly monthly
[Return]
Type the blue stuff and then press the Enter key. This is a System level command, so it will ask you for your system password.

That may take a while if you’ve never done it. That cleans up your UNIX comments and logs which can get very big and slow things down.

  • Are you running short of drive space? That can bring a UNIX system to its knees. Real time applications should have very generous space on a fast drive. You can edit a long, complex show on a spinning hard drive, but an SSD can be significantly faster.

Any of that help at all?

Koz

So am I correct that you don’t seem to be saying that my approach to how I organize the audio is a problem?

I was not aware of the periodic command, so I ran that. Hard to say exactly what it did but presumably something :slight_smile:

In fact I left my laptop open last night so it would have been up at 4am for whatever happens then. Would it going into some sort of sleep/dormant mode interfere with this though?

My drive has about 10% free:
$ df
Filesystem 512-blocks Used Available Capacity iused ifree %iused Mounted on
/dev/disk0s2 623463232 554886528 68064704 90% 69424814 8508088 89% /
devfs 365 365 0 100% 632 0 100% /dev
map -hosts 0 0 0 100% 0 0 100% /net
map auto_home 0 0 0 100% 0 0 100% /home

Opening the “Force Quit Applications” (option-command-escape) shows that I have only a few applications running. Besides Audacity I have a chat program, mail, safari, a terminal window, and the finder. Mostly small stuff other than Safari. Safari has 3 tabs open. One for work, one for gmail, one for this forum.

I can try a reboot later on, right now things are busy at work so it’s not a good time to go offline and try a test.

There are a fair number of icons on my desktop. Not covering the screen, but maybe 1/3rd of it?

I should note that other applications do not seem to suffer from any slowdown, which I would expect to be the case if it was a general system issue.

Next time you do that please use -k or -h so I don’t have to convert in my head.

Would it going into some sort of sleep/dormant mode interfere with this though?

It is suggested that Periodic will not work through Sleep. I don’t know. I know my machines Sleep and rarely Shut Down for months. When I run Periodic, it runs as if it had not run in a very long time.

I should note that other applications do not seem to suffer from any slowdown, which I would expect to be the case if it was a general system issue.

How many other programs do multi-channel, real time streaming? Video is usually the only other program that has problems with a slow or choked machine. How would you know if Photoshop took longer than normal to do a Gaussian Blur or Excel was having trouble calculating a spreadsheet?

“10% free” Makes me nervous. That’s the threshold we tell people on the video forums to stop what they’re doing and make more room. You are using spinning metal, right? One of the System people at work had a roughly similar MacBook to mine. The first time I used his I thought it was broken. “When does it get done with its task? I can come back later…” The only significant difference was I had the SSD.

Do you use Network Drives for anything? Audacity doesn’t understand network delays and trying to perform realtime over a network is usually not a good idea.

I’m going to get in trouble here. I believe Audacity can only use one core. So it doesn’t matter if you have a Core-i7, multi-threading, hoo-ha, Audacity will not see most of it.

Others will jump in here.

Koz

Sorry about that. Here’s a -h version:
$ df -h
Filesystem Size Used Avail Capacity iused ifree %iused Mounted on
/dev/disk0s2 297Gi 266Gi 31Gi 90% 69906395 8026507 90% /
devfs 182Ki 182Ki 0Bi 100% 630 0 100% /dev
map -hosts 0Bi 0Bi 0Bi 100% 0 0 100% /net
map auto_home 0Bi 0Bi 0Bi 100% 0 0 100% /home

So basically a 300GB hard drive with 31GB free. I can look into clearing a bit more space, but the full episode at this resolution is slightly under 300MB, so I have roughly 100x as much free disk space as the episode takes which seems like it should be sufficient.


No, everything is on the built-in hard drive in my MacBook Pro.


I do have dual-cores, so that is something to be aware of, although to the best of my recollection I think things still worked smoother when I was editing based off of one monolithic track.

Perhaps I just have unrealistic expectations or am asking the wrong question. The delays are not “go watch TV” long, or even “go make a sandwich” long. It’s more like 3-6 second delays. Not long in the objective sense, but long enough to be annoying and they are not consistent. Normally this comes up when I’m going through some audio and making edits. So I play a section, hit stop, highlight a short bit of audio, and then press delete to snip it out. Sometimes it’s as short as an “um”, other times it might be several seconds worth. The length does not seem to matter. Sometimes when I delete a snippet it is instantaneous. But other times (and it feels like it gets more common as the project grows in size) I get the spinning beach ball, and there does not seem to be any rhyme or reason when it will be fast and when it will not and I don’t really know what it’s doing when the “busy” indicator comes on that is different from what it’s doing when it doesn’t. For a 300MB project I believe there should be enough memory to work entirely in RAM. If it is related to writing files, perhaps there is a way to have this happen in the background instead?

So I guess what I should be asking is whether I can change any settings or any editing practices to help Audacity work more smoothly and avoid the intermittent delays.

You get the beachball when OS-X allocates time to complete a task and the task takes longer than that. If you get it repeatedly, then there’s an imbalance or a problem somewhere.

Have you run Verify Disk and Repair Permissions?

I think your machine just isn’t up to it. I have an older Mini that was good in its day but was constantly struggling to keep up. I caught myself automatically juggling tasks and settings to make up the difference — in addition to the job I was doing. I finally gave up and got a new one.

The old one (still on-line) was a 1.83GHz Core Duo. It had a slow spinning metal drive, too.

There used to be a setting you could change to tell Audacity how to manage memory, but I don’t think it’s there any more.

There is one thing you can do. There are two different ways to manage imported files. Tell Audacity to make its own personal copies of each one which is safe but slow. Or use reference mode where Audacity goes out and gets them only when they’re needed. Attached. Reference mode was designed to speed up shows with multiple external sound files.

Reference mode is dangerous because when you save a Project, the Project does not have all the music on board, and if you move any of the external files, the show stops working. This used to regularly kill people who were neat and tidy. They would finish a show and “clean up” all the external sound files which would destroy the show.

When you Export the final show, all the music will be there and you can do whatever you like the with Project.

Koz
Screen Shot 2014-10-01 at 10.27.58 AM.png

I’ll try the disk repair options and see if that helps, thanks for the suggestion. It probably hasn’t been done for a long while.

It looks like I’m already using the “read uncompressed (faster)” option.

The laptop is a mid-2010 2.4GHz i5.

You may find that turning that option off improves overall performance a little.
That option can be useful for working on long, single track projects as it makes large imported files available immediately (they are not copied on import) but when editing, changed audio data still needs to be copied so it does not help there. Turning off the “read uncompressed (faster)” option is generally recommended as it is safer to do so (the project is then self-contained rather than depending on external files).

The only other thing I can think of is run Go > Utilities > Activity Monitor. Attached is a drive indication on mine. That graph will tell you all about the drive activity and which direction. If you have any activity at all on a spinning metal drive during editing, that will cause delays, sometimes serious ones.

I know of no way to force Audacity to use memory for everything — short of creating a “fake” drive mount within the memory you have. That’s a heavy system technique and I’m not sure how to do it. But that would have the same effect as an SSD.

Koz
Screen Shot 2014-10-01 at 13.53.17.png

OK, so I ran the Verify/Repair (twice since the second Verify found one more permission to fix), rebooted, installed a couple updates I’d been needing to do, and cleared up a little more space. I’m now at 35gb free.

After these steps Audacity seems to be running more smoothly and I haven’t hit a beach ball yet. It may be a bit early to conclude that everything is fixed as I haven’t done that much editing tonight but there certainly seems to be at least a pretty good improvement.

Thanks for your help!

You would do something like http://www.tekrevue.com/tip/how-to-create-a-4gbs-ram-disk-in-mac-os-x/ .

Gale

I don’t think that is all that unusual. After all it is listed as a bug in the Release Notes.

I don’t think 2.0.6 changes anything here, but you should upgrade anyway: Download Audacity for Mac .

If it happens again, see if Tracks > Mix and Render helps (it makes one track) instead of Align End to End. I don’t expect it will help very much.


Gale