Skipping during recording

Hi everyone,

I’m having a lot of trouble recording my radio show with Audacity using a Samsung GoMic. I’ve had this setup for ages and it’s always worked, but lately I’ve been having problems since I got a new laptop (a Toshiba Satellite Radius P55W). Whenever I record, on playback I discover that after a while, Audacity started to skip every few seconds during the recording, cutting out parts of words. I followed the advice on AudacityTeam ( and re-recorded, but the same thing happened.

What’s strange is that this never happened on my five-year-old HP HDX 16 I was using for this up until last month. I believe I have the latest version of Audacity on the Toshiba (2.1), and the laptop has plenty of memory and a great processor.

What’s happening here? Please help!!



after a while

Did you keep any of the shows? What’s a “while?” 20 minutes? How long are the shows?

Can you post a ten second segment of the show featuring damage? There’s three different, similar-sounding problems and it’s good to know which one we’re dealing with.



The glitching started approximately three minutes into the recording, and lasts throughout the rest. There’s usually 25-30 minutes of continuous recording, and then I go back and edit the talking (which is when I discovered the glitches). The sample is attached to this post. Then there can be 5-10 seconds that are fine, then it gets bad again.

OK. Got it (attached). That straight vertical drop is unnatural. There is a very tiny fraction of your voice that just isn’t there any more. So this appears to be a “machine can’t (or won’t) keep up” problem.

This is where we wait for a Windows elf to tell us what that means.

Just a note. The latest version of Audacity is 2.1.0. Audacity 2.1 or Audacity 2.10 could be bogus versions.

In the Windows installer, there is a place where it asks you if you want to reset all your preferences and settings. If you’re having troubles, the correct answer is yes. That’s the Audacity version of “reinstalling software” anywhere else.

There is one other thing we can do as we wait for the other elves to roll out of bed (Let’s see. 9 hours from Los Angeles… 7:30AM!)

Can you make it worse? Is there anything you can do that makes the problem much worse? You would assume running a bunch of programs at the same time as audacity should drive it nuts. Does it? Can you take the machine off-line, kill the virus software and change the problem at all? Do you leave Skype napping in the corner or kill it completely when you’re finished using it?

Posters get stuck on solving the problem, but any change in either direction is very helpful.

No, I’m not a Windows elf. Sorry.

Screen Shot 2015-06-16 at 22.28.03.png

How much of that did you follow? It’s a process of elimination. Look at every point on Managing Computer Resources and Drivers - Audacity Wiki.

What version of Windows is it? If it’s Windows 8 or Windows 8.1 you could begin by shutting it down fully, also known as a “cold boot”. See If you are on Windows 8.1, you can do the full shut down by using the Win + X menu and choose “Shut Down” from there.


Hi guys,

Sorry for the late response. I followed the advice on the wiki page (disabling various parts of audacity and windows), and that seemed to work for a couple shows, but just now I did all that and the skipping is still happening. No other programs were running on the computer, it was even in airplane mode. Audacity was the only active program.

Just to clarify, this is Audacity 2.1.0.

I am so baffled as to why a new, relatively high-end computer cannot manage something this simple, while a computer half a decade old could do it without issue. This is so frustrating!

Any other advice would be most welcome.


EDIT: Just had to drag my old laptop and the monitor I need to use it (since the screen doesn’t work) over to where I record my show. Way too complex a setup to deal with every week. But sure enough, it recorded without issue, with other programs running and no settings turned off in Audacity. This is so ridiculous. :frowning:

Just to clarify… Did the problem appear when you first got the new PC, or was it working OK on the new PC and then stop working on the new PC? (Has the new PC had this problem from day 1?)

Don’t do airplane mode!

It puts the processor in a low-power, fast sleep mode. Doesn’t work with audio recording on all modern Intel processors.

A tool you can use to show the latency of your Windows setup, INCLUDING the hardware, is DPC Latency Check:

If you are on Windows 8, you might prefer Latencymon:

Do you mean here that because the WiFi and/or Bluetooth are off, the computer is more likely to go to sleep?

On properly designed processors that don’t sleep when the CPU is active every few seconds, turning off WiFi can I believe be beneficial to recording if recording is prone to skipping.


From what I understand about Airplane Mode (AM) on Windows, the results are different with different Windows versions.

Turning off Wifi is certainly a good idea. And turning off most power saving feature might even be necessary to record.

It’s just that AM also affects power settings. Dependent on the exact type of Intel CPU, things happen. For instance, on most Haswell CPU’s, the voltage for the CPU (which is controlled by these power states), could spike. And this spiking could start flipping, meaning switching on and off in a fast repetition. That’s enough to kill (overclocked) CPU’s, or even CPU’s in a laptop-in-bed setting. And it’s a major source of dropouts, even if it only happens once.

I know more or less how OSX and Mac hardware are affected. And only up to Haswell. But I’m not certain at all how the different Windows versions behave, as it is also dependent on BIOS settings. And those are much different from Mac’s EFI.

None of this is a problem if you are on a Core 2 Duo or older. And most of it isn"t a problem for the average user, who won’t even notice a small hiccup. Once you start recording, you can hear the voltage being switched on some computers. Sometimes it’s in your recording, in very rare cases, you can hear the CPU emitting a whistle tone.

And of course, all of this is fixed in later CPU’s. Only to introduce new bugs, such as with AVX:

It seems ffmpeg uses these. And the CPU spike is triggered by them. But it could also be triggered by power state settings on some BIOS’es. And who knows what else?