Simple way to record PC audio - Stereo Mix

I’m looking for a way to record audio from my PC - ON my PC. For example, I watch a video on and I want to capture the audio from it. I thought of running a connector from the headphone jack to my Scarlett 2i2 input, then using that as the input while recording in Audacity.

I couldn’t get that to work too well. It did record … but the voices sounded very low - as if person was far away … other frequencies seemed higher in volume though.

The I tried setting Audacity input to be “Stereo Mix” (I had to go into sound settings somewhere to enable that). That seemed to capture it a bit … but could not hear it. When the video was playing I could see the graphical display of Audacity showing something, stop the video and it’d go flat.

I am using Windows 10.0.19044.1826, and Audacity 2.0.5
Any suggestions ? Thank you for helping.

All the things you have tried should have worked.

With WASAPI (as opposed to MME) you should also be able to record whatever is playing on your speakers via the “speaker (loopback)” on your Device Toolbar device. I don’t know why you can’t hear what you have recorded; perhaps turn the settings all the way up on your Mixer Toolbar. If you Generate > DTMF Tones, can you hear that?

Shortly after I installed 2022-07 Cumulative Update for Windows 10 Version 21H2 for x64-based Systems (KB5015807), my problems began. Realtek HD Audio Manager stopped working. I tried to restore functionality, never did succeed, and then found that Audacity didn’t work. I tinkered with settings for Audacity but it is only recording at very low volumes from streaming audio sites. I’ve turned all Windows audio controls fully up, and the volume is still pitifully low. I’m using Audacity 3.1.3. Is the latest Windows version/update incompatible with Audacity?

Make sure [u]Windows “Enhancements”[/u] are turned OFF.

WASAPI (loopback) almost always works, except there has to be sound playing. (It can be silent, but there has to be an “audio stream” or it will stop recording, or it won’t start.)

Stereo Mix is becoming rare. I believe it’s a “driver feature”. But if it shows-up as an option it should work too…

Both of these “capture” the output from the soundcard/device so if the Focusrite or any other audio device) is connected be sure to select the correct device where tge sound is coming out.

Curious. My machine just did a Windows update last night and I lost my “Stereo Mix”. To restore it: run mmsys.cpl, Recording; Right-click > Show Disabled Devices; Right-click on Stereo Mix > Enable). Then in Audacity: Transport > Rescan Audio Devices

In Audacity, also try Tools > Reset Configuration.

It is also possible that you are trying to record through your microphone. For loopback recording, check your Device Toolbar; make sure your host is Microsoft WASAPI and recording device is Speaker/headphones (loopback)

jademan, Thank you for your input. I went down your suggestions one by one with no joy. Then I noted this right at the bottom: “It is also possible that you are trying to record through your microphone. For loopback recording, check your Device Toolbar; make sure your host is Microsoft WASAPI and recording device is Speaker/headphones (loopback)”. Followed through, and now I’ve got usable volume again.

I still wonder what happened to RealTek Audio Manager. There was a lot more volume with that, as if running it added a higher-power audio amplifier.

Ran into the same issues with the laptop that I use, so the next step will be to change Audacity settings on there.

Hello Jademan, Thank you for responding to our questions. I just updated to Audacity version 3.1.3 (most recent as of today) - and I’m running Windows 10. My “Stereo MIx” is enabled, and I ran Rescan audio devices. I also ran Reset Configuration.

I restarted Audacity, set Audio Host to “Windows WASAPI”. There was no recording device of “Speaker/headphones (loopback)”, only “Communication Headphones (IDT High Defi”, “Internal Microphone Array (IDT High Definiti” and “Stereo Mix (IDT High Definition Audio Code”. So I set it to the last “Stereo Mix …”.

I set audio volume mid level, started some video on CNN, sound was somewhat loud … started recording. Upon playback, sound level is somewhat low … turning it all the ay up it is still noticeably lower … perhaps 1/3 what volume was when video was playing.

Any ideas on what I might try ?

Again, thank you all for trying to help me.

Sometimes the Device Toolbar cuts off the name of a device in its drop-down box. If you select the device, then hover over the selected device name in the Device Toolbar, then more characters may appear in a special display. In my case, when using WASAPI,

“Speaker/Headphone (realtek High Definition Au” appears in the drop-down list,
“Speaker/Headphone (realtek High Definitio” appears as the selected device, but
“Speaker/Headphone (realtek High Definition Audio (loopback)” appears when I hover.

Alternatively this same information is available as Help > Diagnositics > Audio Device, but is a little harder to sort through. Hint: Copy/paste to Notepad, then search for WASAPI.

(In Audacity 3.2, to be released within the next few months, a new Device Selection screen appears which doesn’t appear to cut off the names of audio devices, at least with WASAPI).