Significant Delay in Live Monitor

I recently upgraded to version 8.4.2…whatta mistake to make!

Since the upgrade I now have a significant delay when using live monitor.

For years I have been recording my guitar playing. My standard operating procedure was to plug the heaphone output of my amp into my computer and use the monitor function in Audacity to hear what I was playing while recording. Everything worked well and without issue… then I upgraded to version 8.4.2 and now using the exact same procedure, I have a significant delay in hearing the monitor.

The delay is so bad that I am no less than two whole notes behind what I am playing, even in slow time. If I try to play a fast riff while using monitor …well forget it!

I’ve tried listening with headphones, and also just through my laptop on board speakers; The effect is the same.
What happened in the upgrade to cause this? Is there a work around?

I dont know if this screen capture image will work, but you can see what is available during the “Preferences” set up. I have ticked and unticked every combinatin of radio buttons, only to get the same result.

BRING BACK THE OLD VERSION!!! At least it worked.


Older versions here

You can try decreasing the Buffer size. (I assume this only adjusts the recording buffer.)

There is ALWAYS SOME latency (delay) through the computer because there are recording & playback buffers. The buffers are required because the multitasking operating system is always multitasking & interrupting even if you are only running one application.

Sometimes you can get the latency down to where it’s not noticeable. ASIO drivers are designed for low-latency, but Audacity doesn’t support ASIO (unless you compile it yourself) and the root problem isn’t usually the drivers anyway.

With a guitar you can usually hear the guitar or guitar amp. But many audio interfaces have zero-latency direct-hardware monitoring, or there are USB mixers that double as audio interfaces, etc.

There is a FREE online book about optimizing Windows for audio called Glitch Free.

Many thanks for your input and especially the links to older versions. I will most certainly try and revert back to an older version first as I know that at least one older version was perfect.

As for the comment about “inherent latency” being the standard…while I do understand that software and the interface can, and do, create delays, I’m not sure why that would be applicable now. Nothing has has changed in my standard operating and set up procedure when everything worked as it should and without delays. The delays only started started as a direct result of the upgrade to 8.4.2. Its almost as if they have introduced a Bucket Brigade Delay Line, or similar attribute, into the application.

Hopefully reverting back to an older version will solve this issue.

This topic was automatically closed after 30 days. New replies are no longer allowed.