"side-by-side configuration is incorrect" error with 2.0.5


After installing Audacity 2.0.5 from the .exe installer on C: drive, I receive this error message when trying to launch;
“The application has failed to start because its side-by-side configuration is incorrect.”

I am using Windows 7 Professional 64-bit with SP1 installed.
Have installed Microsoft Visual C++ 2008 SP1 Redistributable (x64) to no avail. I have even uninstalled & re-installed it several times.

I have searched the archives here and have found some help from the Help pages but Audacity will still not launch. :frowning:

Any ideas? I’ve never encountered this problem before and it really has me stumped. Thank you.

‘Dependency Walker’ (for Win64) examining audacity.exe tells me that these files are missing:


You could try searching in C:WindowsWinSxS for “msvcp90.dll” and “msvcr90.dll” (without quotes).

Then in the folders that those files are found in, rename “msvcp90.dll” and “msvcr90.dll” to some other name, then copy “msvcp90.dll” and “msvcr90.dll” from the Audacity installation folder to the folders containing the renamed “msvcp90.dll” and “msvcr90.dll”.


Well, that was a lot of finger effort but I got all the files renamed and copied Audacity’s two DLL’s to each corresponding folder per your instructions…

Still the same side-by-side error message. :cry:

Thank you for the advice, but do you have any other ideas?


Did you get the Audacity installer from http://audacityteam.org/download/windows ?

The correct DLL’s that I asked you to copy are already in the Audacity installation folder - the problem in these cases is getting Windows to look in the correct place first for them.

Have you verified those files are actually missing? They should be in C:WindowsSystem32.


Yes. These files are indeed missing. I’ve went out and found the 64bit versions from some DLL sites and have replaced them.

Audacity still encounters the “side-by-side configuration” error. :cry:

I’ve done quite a bit of investigating with the MicroSoft Event Viewer and have noticed that Audacity appears to be looking for a wholly different version of the Microsoft Visual C++ redistribute package. [see attached file]

Microsoft Visual C++ 2008 SP1 Redistributable (x64) is version 9.0.30729.17

At this point I am almost ready to get into the Registry and do some editing; I think the registry key might be this:


But I really don’t know what values to assign…so I guess I’ll hold off for now…

Anyway, this is where I am currently.

side-by-side configuration Event log.gif

My impression is that you are very knowledgeable and perhaps some tweaks performed or advanced programs you have installed have caused this.

Here is what the Microsoft.VC90.CRT.manifest contents that come with Audacity should contain:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
    <assemblyIdentity type="win32" name="Microsoft.VC90.CRT" version="9.0.30729.1" processorArchitecture="x86" publicKeyToken="1fc8b3b9a1e18e3b"></assemblyIdentity>
    <file name="msvcr90.dll" hashalg="SHA1" hash="9785b1c493deb5b2134dc4aef3719cee207001bc"><asmv2:hash xmlns:asmv2="urn:schemas-microsoft-com:asm.v2" xmlns:dsig="http://www.w3.org/2000/09/xmldsig#"><dsig:Transforms><dsig:Transform Algorithm="urn:schemas-microsoft-com:HashTransforms.Identity"></dsig:Transform></dsig:Transforms><dsig:DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha1"></dsig:DigestMethod><dsig:DigestValue>VF5ECUAHPV7EnUf+/UIXMPizPvs=</dsig:DigestValue></asmv2:hash></file> <file name="msvcp90.dll" hashalg="SHA1" hash="0f6bbf7fe4fb3fca2cb5b542eca1a1cad051f01c"><asmv2:hash xmlns:asmv2="urn:schemas-microsoft-com:asm.v2" xmlns:dsig="http://www.w3.org/2000/09/xmldsig#"><dsig:Transforms><dsig:Transform Algorithm="urn:schemas-microsoft-com:HashTransforms.Identity"></dsig:Transform></dsig:Transforms><dsig:DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha1"></dsig:DigestMethod><dsig:DigestValue>3Wg+StVMq2uhx7POnAkl2w4dDmY=</dsig:DigestValue></asmv2:hash></file> <file name="msvcm90.dll" hashalg="SHA1" hash="7f3290ab2b7444c2b4a9b1fedfdb16466d7a21bb"><asmv2:hash xmlns:asmv2="urn:schemas-microsoft-com:asm.v2" xmlns:dsig="http://www.w3.org/2000/09/xmldsig#"><dsig:Transforms><dsig:Transform Algorithm="urn:schemas-microsoft-com:HashTransforms.Identity"></dsig:Transform></dsig:Transforms><dsig:DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha1"></dsig:DigestMethod><dsig:DigestValue>/YfRn7UQENzdMeoMHxTgdRMiObA=</dsig:DigestValue></asmv2:hash></file>

Obviously you could try deleting C:WindowsWinSxSManifestCache or try editing the *vc90.crt.manifests in C:WindowsWinSxSManifests so they are the same as in the above code.

Alternatives would be to backup your data and reinstall Windows given files were already missing, or perhaps compile Audacity yourself in which case it should by definition run on your machine at least.



I think I have Audacity working now! (I have yet to record with it…)

I followed these instructions from a MicroSoft Office Access support page: http://support.microsoft.com/kb/2525435

I followed my Event Viewer error log as hints and edited the registry and made sure that “Microsoft.VC90.CRT.manifest” file was pointed to the matching version; 9.0.30729.1 in the HKEY_LOCAL_MACHINECOMPONENTSWinnersx86_policy.9.0.microsoft.vc90.crt_ key of the registry.

***I forgot to mention that I think my issue came about because I uninstalled a couple of free trial video-editing programs and I am guessing that they “took” some of the registry keys and some of the windowswinsxs & windowssystem32 files with them. [GRRRRR!!] :imp:

Anyway, now I have to get Adobe Photoshop Elements 12, Advanced MP3 Converter and an old copy of WinAmp working again as well.

Thanks again Gale! I’ll let you know how Audacity is working! :smiley:

OK thanks for the support link. I did not know about that registry key, but all the “difficult” cases I’ve fixed for people have involved making the msvc* files and the Microsoft.VC90.CRT.manifest contents the same all over the computer. I wasn’t told it broke some other application, but of course it could do.

So are you saying you had to set the (Default) string value in that key to “9.0.30729.1” as per the Microsoft.VC90.CRT.manifest shipped with Audacity? I was a little sceptical because I only have one number in that key which is “9.0.30729.8387”, but I don’t have an issue with the Audacity release version.


That is correct. I changed the string value in that key to 9.0.30729.1. And, if I recall correctly, the string was at “0” when I first looked at it. And that would explain why Audacity and and a few other programs were no longer working.

Audacity is working great for me again! I am once again able to record my vinyl at 24-bit for processing through ClickRepair. :smiley:

Thanks again!!

I’ll just post here that someone else who reported the “Activation context generation” error (even after installing the redistributable pack) told me they solved it by running Audacity as administrator.

If so, it would be safer than editing the registry.

Does the HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionSideBySideWinnersx86_policy.9.0.microsoft.vc90.crt_ key have the exact same name on all machines? I assume not, but mine is HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionSideBySideWinnersx86_policy.9.0.microsoft.vc90.crt_1fc8b3b9a1e18e3b_none_02d0010672fd82199.0 .


On my system, setting the string value to “9.0.30729.1” causes the side-by-side error. It has to be set to “9.0.30729.8387” which is presumably the highest number that exists.

Perhaps it works for you given you made all copies of the msvcr90 and msvcp90 DLL’s the same as Audacity’s ( 9.0.30729.1 ).

Anyway it seems there is little case for making a .REG file since it’s unclear if it would work in all cases.