"Side-by-side configuration error" after Windows 10 update?

Last night my laptop ran a Windows 10 update, and since that update I have not been able to use Audacity (2.1.1). Whenever I go to run my saved project shortcut or even open the application at all, I get the filepath and the following error:

The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.

I’ve spent most of the day trying to run down a fix for this- Microsoft had something about editing the registry, which I’m not at all comfortable with and also didn’t appear as though it would solve my issue. Best I could think to do was copy my projects in progress to an external drive and uninstall/reinstall Audacity but I get an error in Control Panel saying it may have already been uninstalled. I tried installing from the website and after a few times attempting to click on the downloaded installer in my tray, it disappears.

Has anyone else experienced any of this, and is there a fix on this end? Or do I need to go harangue Microsoft about the update playing nice with my installed apps?

Did you get Audacity from us?


This error can occur when a DLL file has been corrupted or deleted, or if it simply does not yet exist on the machine (in the case of upgrade installs of Windows). This may be a symptom of a virus trying to access DLLs and subsequently corrupting them, an imminent HD failure, bad update, or any number of other causes.



I have doubts about the side-by-side error being the actual cause of the problem, but you could try installing the new Audacity 2.2.2 beta version, which has a fix for the side-by-side error. The beta version is available here: https://www.fosshub.com/Audacity-devel.html/ (be careful to use the text links, and ignore any big green “download” buttons).

Let us know how you get on.

Thanks for the quick reply!

I attempted to download the beta of the latest version and when I try to open the .exe file I downloaded I get the same error message.

Hi Koz,

I did download it straight from that website and it’s been running fine for a few years now. Thanks for that link- it appears to address the issue but I’ve read it several times and I’m not sure I understand how to do what it says.