Show logs

Why is there something in Help - Diagnostics - Show log every time you open the program, even immediately after clearing logs? The program works correctly, without error messages, failures. Where are the errors got from?

It tryes to load ffmpeg libraries. Why? I import mp3. Can I get rid of these attempts and messages?

FFmpeg is an optional component. Some codecs that it supports may be reverse engineered proprietary formats and may be subject to IP laws in some countries, so some people prefer not to install it. There may also be a legal risk for apps that have FFmpeg built in, though I’m not aware of this ever being tested in law. See here for more information:

By making FFmpeg an optional component that can be automatically loaded at run time, people that want the functionality afforded by FFmpeg can install it, and those that don’t want to, and/or believe that it is not legal in their jurisdiction, can choose not to install it. For this to work, on launch, Audacity has to look to see if FFmpeg is installed. That’s what those messages are about.

You can get rid of those messages by clicking the “Clear” button.

Thank you! Can I turn this verification (whether ffmpeg is installed) off? I don’t need it. For I can clear logs but they right away, on the next launch, appear again.

There are no user controls for logging other than the three buttons in the log window. The log window is intended for developers, and to help us help you in the event of problems. There’s really no reason to poke around in there unless you are having problems or doing some kind of software development.

They interfere with real error reports.

I’ve installed ffmpeg. The error line in logs still appear.

Why is it written, that Hum remover returned?
Indeed the effect was applied successfully.

WARNING: floor must be greater than zero in GATE function; setting floor to 0.001.
What does it mean? I attach the saved document with logs.
log.txt (2.23 KB)

It’s a “log” file, not just for errors. Audacity also logs other important information.

Audacity searches multiple locations for FFmpeg as it’s location depends on how it was installed. Audacity uses a “try catch exception” approach, which is a standard programming technique: Try doing it one way, if that does not work, catch the error and try another way…

This information may not be useful to you personally, but Audacity wasn’t created just for you. The information can be extremely helpful if a user has a problem with FFmpeg. The line: “FFmpeg library loaded successfully” indicates that for your, the FFmpeg library was loaded successfully.

The next line is what it returned:
“WARNING: floor must be greater than zero in GATE function; setting…”

That indicates a recoverable error in the Hum remover plug-in code. The reason for that error is due to an update to Nyquist’s GATE function that was made some time after the Hum remover plug-in was written. Does the plug-in still work?

Yes, it works, I attached the screen in previous post. In history it is reflected “Applied effect Hum remover”.

Please, correct the plugin’s work so, that debug output would be empty.

Why do you think that’s my job? Can’t you fix it?

I chose in random 5 or 6 Nyquist plugings - none of them gave anything in debug output. Logically, Hum remover should be like the others.Whose job it is, I don’t know. It’s not mine!

Audacity has been developed over 20 years by volunteer enthusiasts, creating not only a great audio app, but building a community. Hundreds of people have contributed over the years, and millions of people have benefited from their work. When I first started using Audacity, there were some bugs and missing features that I wanted fixed, so I learned how to contribute. There’s no reason why you couldn’t do the same :wink:
There are people here on this forum that would be very happy to help you learn, but don’t expect them to do it for you.

What if open the plugin with Notepad and then merely replace the (floor) value 0.00002 with 0.001?

(setq floor 0.00002)
(setq odd (sanitise odd 0 1000))
(setq even (sanitise even 0 1000))
(setq thresh (/ (sanitise thresh 0 100) 100.0))
(setq attack 0.25)
(setq look attack)

I can’t believe, the error message is gone! But how would it be better, to set the new value or to get back the old? Or to set some other value?

That’ll do it.

I guess, the better setting will be “floor”=0.0008 (eight divided by ten thousand)
The error line still presents. I’ve done all I can. Please make the mistake go away.