Several troubles using VST Plugins with Audacity 2.1.0

Hi everyone,

Today I had a lot of troubles using Audacity with some VST plugins, like Ambience, Anechoik room simulator, BionicDelay, ChimeMachine, etc. And in sumary, this is what happened:

  • In plugins like Anechoik Room simulator or sometimes in Ambience, there are some parameters that aren’t played during a preview playback; in the most cases, Audacity simply applies the effect with the default parameters, or the last used, if you try to change to another one. However, if you apply the effect to the audio file, it is applied with the chosen options.
  • Some plugins also crashed when trying to apply them. For example, it occured trying to load a plugin called Glaceverb.

Note that I disabled the graphic interface due to accesibility reasons, and the options are as default. I’m using Windows 7 (64 bits).

In addition, I tested some effects with a Buildnight Audacity version (2.1.1R3) but it loaded all my plugins pholder in spite of there was none of my plugins due to obvious reasons, and I couldn’t load some of them (Audacity showed me a fail message). “Audacity couldn’t load the selected plugin. You can get more information in Help”. Sorry if I coudln’t write the exact text.

Then, what could I do for fixing this? I’d like to get a reply, since it’s sad to lose the oportunity of use some great plugins.

Thanks a lot!

VST plugins which work with Audacity are listed here …

[ Any VST which has real-time interaction doesn’t work properly, or at all, in Audacity :frowning: ]

Well, but with the plugin Ambience (which is in the Wiki) I have the same problem than the others, at least choosing a specific preset, while with other settings the plugin is working fine. Even Im able to make changes in its parameters, such as decay time, pre-delay, etc, and the setings are changed in real-time.

But then, isn’t this about some DLL’s in this version of Audacity?

To be clear, now Audacity has real-time preview for VST effects, the limitation is that Audacity cannot allow an effect to change audio data in real time.

So for example Audacity doesn’t allow an effect to modify audio while it is being recorded.


Thanks for the report.

Have you tried exiting Audacity then deleting the file “Users<your user name>\AppData\Roaming\Audacity\ pluginsettings.cfg”?

Otherwise, can you be more specific for both effects exactly which parameters cannot be changed in real-time?

If you close the effect after apply, Edit > Undo the effect then reopen the effect, can the parameters you changed before now be heard when previewing?

Please try that effect in 2.1.1rc3. Glaceverb does not crash for me in that build with a 10 minutes mono track.

I cannot understand exactly what you are saying, but Audacity 2.1.x tracks each location in which it has ever detected plugins.

So if you launched 2.1.1rc3 from a different folder than the folder 2.1.0 was in, and the Audacity “Plug-Ins” folder in each location had the same shipped Nyquist plug-ins, then Audacity will list each such plugin twice in the Effect menu.

If you moved some VST plugins from the Audacity 2.1.0 “Plug-Ins” folder to the Audacity 2.1.1rc3 “Plug-Ins” folder then these VST’s will be listed twice in the Plug-ins Manager. The effect that was in the 2.1.0 “Plug-Ins” folder will be listed as “Disabled” and the effect that is in the 2.1.1rc3 “Plug-Ins” folder will be listed as “New”.

If it is too confusing I suggest you quit Audacity and delete the file “Users<your user name>\AppData\Roaming\Audacity\pluginregistry.cfg”.



Oops :blush: , real-time-preview is not on the copy of Audacity I have : I need to get a the latest copy.

Hi, good news: after all, I’ve tested again the plugins “BionicDelay” and “Chime Machine”. And fortunatelly, I could set up the parameters in bot plugins; maybe I was setting it up wrong, but I didn’t like the plugin Chime Machine :smiley:. But also, Bionic Delay crashed in some times; but maybe it doesn’t mater so mutch.

However, I have made some tests with Ambience reverb plugin, and I’ve realized that: As I said in the previous post, if you choose a preset from the dropdown menu, sometimes it doesn’t work, and the parameters are applied until you press the “apply” button, But I also saw that if you move its sliders, they are working properly. Anyway, the parameters change like it was in other preset, not the new preset. Sorry if I’ve made some mistakes in the report.

Yes, and the results were the same in all cases.

No, if for some reason you load the first preset, then preview the file, load another preset and preview the file again, the parameters are of the first preset.

For example, let’s asume that we want to preview a voice clip with a preset called “Vocals” (it’s an imaginary preset), but we thought it sounded with mutch colour. Then we prefer to select another called “vocals 2”, which has a darker sound than the first preset. But the problem is that the effect is procesing the sound with the first preset (vocals) not the second (vocals 2), but if you press apply buton, it’s possible to listen those changes. And if you want to open the effect again, the parameters are the same; they aren’t changed like we were applied them to the file.

I tried to be as clear as possible; if you have questions please post them.

Speaking about Glaceverb, in my old Audacity 2.1.0, it definitely crashes when previewing. For example, I recorded a voice and I tried to appli this. I pressed the preview button, but when I wanted to stop it and play it again Audacity crashed. This doesn’t happen in other hosts.

yes, I understand why some effects was disabled and the others was enabled. In fact, I thought it was a bug from Audacity.

Thanks a lot for your answer!

Yes I can see what you mean in Ambience, iZotope Vinyl and “Get Lost, Singer”. It makes no difference if you use graphical or textual interface.

Do all the VST’s you tried that have factory presets have this problem?

As a workaround, try changing the preset while playing the audio. Or save a user preset instead, or restart Audacity to hear the loaded preset.

At least in Ambience, restart playback to hear the loaded user preset. In “Get Lost, Singer”, when I started playback, loaded a user preset then loaded another user preset, I heard both presets combined until I restarted playback.

There is no “Preview” button named as such for VST’s in 2.1.0. There is “Start Playback” which when pressed becomes “Stop Playback”.

Again, I suggest you try this in 2.1.1rc3. Glaceverb does not crash for me in 2.1.1, in either graphical or text mode.

Thanks again for your report.


No, just the mentioned VST’s and maybe others. For example, it is working fine in Classic reverb, Classic Delay, Obnyverb and in Azurite (a chorus effect).

I created a bug report for this which you can follow:

The workaround of saving a User Preset does not seem valid - testing in other effects than Ambience, User Presets also can’t be previewed if you select the preset when playback is stopped. I think the fact that Ambience does not always display this problem was confusing the issue.

Selecting the Factory or User Preset while playing always seems to work so is the best workaround.