Setting M-Audio Mobile Pre as audio input


I have an M-Audio Mobile Pre and a Shure Microphone setup, and would like to record from that source. The equipment is plugged in and working, but my Preferences does not give me that option as a recording device. I can record just fine from my internal mic on my computer, so there’s no problem there.

Any suggestions?



check the tutorial/tips here for how to connect a usb device
if it uses asio it wont work with audacity.

why not use the software that came with the mthing to record
and use audacity to edit?

I looked in tutorials/tips and did not find anything about connecting a usb device. I know that this system works, by the way, because I used it on my previous computer. My new computer uses Windows 7, if that makes any difference. I just need to find a way for Audacity to detect the external usb mic device so that I can utilize it.

There’s a page here about USB Turntables. Much of the information on this page also applies to recording with external USB sound cards.

time to rename that page usb devices
and make TTs a section
plus add a few words about mikes, interfaces, etc.

Thanks guys…

Still having problems getting Audacity to recognize the usb input. I followed all of the instructions and troubleshooting tips, and for some reason, it still does not recognize the usb input as a recording option.

I checked, and the Mobile Pre amp is working fine, current drivers, etc. I disabled the internal mic on the computer, all to no avail.

I still have my old computer (with Windows XP), and as a last resort could use it for recording. Eventually, however, I need to record on the new computer.

Any more suggestions?

many places diddle the audio

do you have the latest drivers ?

check the drivers settings
check the opsys settings
check audacity settings last

  1. Plug in the USB interface and reboot the computer.
  2. click “Start > Control Panel > Hardware and Sound > Sound” (if you’re using “Classic View” there’s a direct link to “Sound” in the Control Panel), then click on the “Recording” tab.
  3. Check that the USB device is enabled as a Recording device as indicated here (scroll down to the picture below the blue text box)

Success! Got it working. Thanks a lot for your help and your patience in working through this with me.

now tell us what worked for your problem
others may have it too and would like to know the trick

I imagine he followed the instructions in the previous post.

maybe not
lots of folks post that something else fixed their problem
after they got clues from the replies

There is a saying “If at first you don’t succeed, RTFM” :wink:

All I did was to listen to the question, then suggest a safe starting point and indicate to the user the appropriate part of the documentation.
It can be useful to other users when, as in this case, there is a resolution to a problem at the end of the topic.

If this was not the solution that worked for wgdefoore, then hopefully he will come back and clarify what did work, but unless/until wgdefoore does so, let’s just assume that the official Audacity documentation is correct. :wink: