Set to stereo but records mono or one channel


I have Windows 10, this is a fairly new computer and I have been using Audacity since 2013 for “ripping” vinyl records. Never had an issue until this computer.

Something on the recordings has sounded “off” and I could not figure out what it was until now. I have it set to 2 channel stereo, line in is USB AUDIO CODEC. Nothing has changed with my record player, only the computer has changed.

Anyway, it seems to be recording in mono or only one channel but still displays stereo tracks. Example: When recording “Hello, Goodbye” by The Beatles I cannot hear the guitar parts in one channel and the stereo separation when John sings “Hello Goodbye” is not heard.

I have no idea why it started doing this because it has never been a problem in the past. I have also tried setting to MME, Windows Direct Sound and WASAPI and results are no different with any of the settings.

I have attached an audio sample where you should hear a guitar just after 2 seconds and “Hello Goodbye” cannot be heard at 11 seconds.
audacity mike.JPG

Good. Also, try running “mmsys.cpl” from the Windows search bar. Select the Recording Tab > Your USB AUDIO CODEC > Advanced. Check that the Default Format is 2 channels. Check the other tabs to be sure that all “Enhancements” are turned off.

OK thank you. I checked and it was already set at 2 channels but still only records mono as in the mp3 above. No idea why this is happening.
line in.JPG

What is your USB AUDIO CODEC? Have you tried switching the leads from the turntable?

No, have not switched anything. It is the same as it always was, the only difference in the computer.

I assume by USB AUDIO CODEC you mean the cable? One end (turntable end) has a printer plug on it the other end has usb which plugs into the computer.

Sorry, I might be misunderstanding you.



Another photo where all appears normal. used MME this time but that doesn’t seem to matter what I changed it to, it still records. This one is a Jazz record from the 60’s (lounge music with lots of stereo gimmicks that were popular at the time) and it is no different - only one track.

Just noticed this part. I will try this when I get home tonight. As you can see from the photo in my settings Enhancements are turned on. Maybe this will clear it up. I don’t rip my collection as much as I used to (because I have done most of them) but on occasion I’ll get a new record I want to hear at work or while driving.

Yes - what model ?

I bought the cable in 2013 so I don’t remember all the details. I just know I bought a 15 footer so the turntable would easily reach the computer. It might be this or similar to it

I remember it was dirt cheap but that was a long time ago.

And the cable itself has always worked. Turntable is an Audio-Technica LP-120 USB. It came with its own cable but was way too short so I bought a longer one.

And the turntable model?

Update: never mind, I see it now…

Your input device spec "Line (2- USB AUDIO CODEC) looks a little suspicious; can you run Help > Diagnostics > Audio Device Info, then post the results?

Here are some other thoughts:

  1. Try WASAPI
  2. See: Mono Recording from Audio-Technica LP120 [SOLVED]
  3. See: Audacity not recording in stereo [SOLVED]

Yes, will do it when I get home from work this evening. It kind of baffles me because nothing has changed except the computer. It is set up just like before but I do suspect “Signal Enhancements” and will try that before trying anything else. Someone else also suggested that to me so I am hoping that is all it is.

Unchecked Signal Enhancements and that worked!! Thanks, problem solved!

Glad to hear everything is working now. :smiley:

Have you check the leads from the record deck to the computer?

bridgesbunch wrote: “Unchecked Signal Enhancements and that worked!! Thanks, problem solved!