Selection starting point jumps when dragging [SOLVED]

Hi there,

I really like Audacity but something is driving me insane at the moment. When I click, hold and drag to make a selection the starting point of the selection suddenly slips and jumps to a new starting point. I often listen carefully and zoom into the waveform to find just the right spot for the selection to start, but then it jumps somewhere else when I drag to make the selection :astonished: It doesn’t happen every time but maybe 50-70 percent to the time, and it’s driving me nuts I don’t know if there’s some “snap to” setting I’m missing or if it’s a Windows issue, so I could really use som help :unamused: Hope someone has a sollution - thanks in advance! :stuck_out_tongue:

I’m using Windows 10 and Audacity 2.1.2 with the .exe installer.

Does it jump while you are dragging? That is, does it start making the selection correctly and then suddenly the start of the selection jumps toward the mouse pointer?
If so, then it’s probably your mouse. This happened to me recently - and it was because the mouse button switch was starting to wear out. $5 for a new mouse later and all was well again.

Oh my goodness Steve, I think you solved it! :stuck_out_tongue:
I had another mouse lying around and after switching to it, I have been unable to reproduce the annoying and erratic behavior. And yes, the start of the selection was jumping toward the mouse pointer. What a relief! :stuck_out_tongue:

Thanks so much Steve! :stuck_out_tongue: